Theme/component installation error

Hi, I’m developing a theme component for a project and created a GitHub repo for it, but when I try to install it (or any other remote theme/component) in my local development instance, I just get a 500 error. This is what I’m seeing in the log, but I’m not sure how to debug further?

Completed 500 Internal Server Error in 780ms (ActiveRecord: 1.6ms | Allocations: 61496)

Errno::ENOENT (No such file or directory - timeout)
lib/discourse.rb:150:in `execute_command'
lib/discourse.rb:127:in `exec'
lib/discourse.rb:34:in `execute_command'
lib/theme_store/git_importer.rb:121:in `execute'
lib/theme_store/git_importer.rb:54:in `version'
app/models/remote_theme.rb:193:in `update_from_remote'
app/models/remote_theme.rb:93:in `import_theme'
app/controllers/admin/themes_controller.rb:104:in `import'
app/controllers/application_controller.rb:387:in `block in with_resolved_locale'
app/controllers/application_controller.rb:387:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:71:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
config/initializers/100-quiet_logger.rb:23:in `call'
config/initializers/100-silence_logger.rb:31:in `call'
lib/middleware/missing_avatars.rb:23:in `call'
lib/middleware/turbo_dev.rb:34:in `call'
  Rendering /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack-
  Rendering /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack-
  Rendered /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack- (Duration: 0.4ms | Allocations: 441)
  Rendering /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack-
  Rendered /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack- (Duration: 0.4ms | Allocations: 286)
  Rendering /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack-
  Rendered /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack- (Duration: 0.3ms | Allocations: 332)
  Rendered /opt/homebrew/lib/ruby/gems/2.7.0/gems/actionpack- (Duration: 15.6ms | Allocations: 7673)

Have you tried the Beginners’ guide to using Theme Creator and Theme CLI to start building a Discourse theme. Does it work that way?

D’oh! :man_facepalming:t5: Thanks, Jay! I already had the Theme CLI installed, I’d just forgotten about it. That works fine.

1 Like

Well, then you’ve got the theme part right.

Is it in a public repo? Maybe that’s the part you’ve got wrong.

Yes, it’s in a public repo, but I get the same error even when I try to install official themes and components. I’d love to figure it out though, as I’m working on two components, so plus the two needed for Discourse itself, that means I need to run a total of four terminals for each session :grimacing:

Are you behind some kind of firewall or some strange network?

No, just a regular home broadband connection and wifi network, no estoric network configuration.

1 Like