declined the connection

So I just set up Discourse using DigitalOcean’s 1-click-app, though when done I ran into a problem.

When visiting my website I see this:

(Sorry, I’m Dutch, but I’m sure you recognize this)

I use Cloudflare and have the SSL mode set to full (so not full (strict), just full).

Any help would be appreciated!

1 Like

Don’t use the DO one click install. That’s not supported here. Use the official install


Why though? Using the one-click install should work and is a valid way of installing Discourse.

We, the Discourse team, did not create the one-click install, and much of what it does is a black box to us. As such, we limit the support provided here on Meta to those that follow our official install instructions, as we know how they work and how to troubleshoot. There are simply too many unknown variables with the DO one-click.

Note that it is a low-priority, long-term todo on our list to look into taking over the one-click install. However, as of now, there is no formal timeline to do so.


You can probably set cloudflare to dns only and rebuild and it’ll work, but since you didn’t follow the install directions you won’t know how to rebuild.


From your other thread that is now closed:

This is just the hostname of your Digital Ocean droplet (i.e. server’s name), so it’s not related to the name of your forum. If you want to change that, the cleanest way is just to deploy a new server and specify a different hostname to Digital Ocean on creation. It can be changed after deployment as well though.

To rebuild:
Navigate to discourse folder:
cd /var/discourse

Check/update your configuration:
nano containers/app.yml

Then rebuild with the new config:
./launcher rebuild app

If using Cloudflare, make sure to add the Cloudflare template to the app.yml (just to make sure your IP logging is for real IPs, not Cloudflare ips). The section is at the top of the app.yml.

- "templates/cloudflare.template.yml"

+1 for the advice above of setting up using the official instructions.

First off, thanks for your reply! It’s already set to DNS only. I guess I’m just gonna go with the official instructions right now because I will have to one day (for plugins) and moving is another complicated thing.

Thank you for the reply too! Yeah, I guess I will go with the advice of using the official install for multiple reasons. It may be a bit complicated since I don’t know that much about web-developing, but with the nice instructions it’ll be fine.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.