Digitalocean 1-click Discourse install

I am getting an error while trying to complete the Digitalocean Discourse 1-click install.

Checking your domain name . . .
WARNING: Port 443 of computer does not appear to be accessible using hostname:
WARNING: Connection to (port 80) also fails.

The droplet’s IP address is The nameserver for is TMDhosting, and using the cpanel there I have the following zone records for the domain:

NAME                          TTL  CLASS  TYPE  RECORD     600   IN    A 600   IN    A

On checking the firewall settings by running:

sudo ufw status

I get:

To               Action      From
--               ------      ----
22/tcp           LIMIT       Anywhere
80/tcp           ALLOW       Anywhere
443/tcp          ALLOW       Anywhere
22/tcp (v6)      LIMIT       Anywhere (v6)
80/tcp (v6)      ALLOW       Anywhere (v6)
443/tcp (v6)     ALLOW       Anywhere (v6)

Can anyone tell me what I’m missing? Many thanks in advance.


I think DO one click is not a community-supported setup. I think you should reset your droplet instead and go ahead with this one.


Thanks @fzngagan. I didn’t appreciate that.

I have posted similarly to the Digitalocean community support forum. If it gets solved there, I will post the answer here for the potential benefit of others who may find themselves in the same situation in the future. Otherwise, I will kill the droplet and have another go with the method you outline here. Thank you again for that.


Thanks again @fzngagan. With no responders to my plea for help over on the Digitalocean support community, I killed my first droplet and started again following the instructions you shared with me here. Worked first time. Cheers!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.