Tiles Image Gallery

Why we can not use tile image gallery when the image is only 2 ? It shows just 1 “thumbnail” image. But when the image are 3 and more, it works. Hope, someday, tile image gallery can works even only 2 images on it.

Thanks a lot

1 Like

So, I’m having this component fail for me. I installed it on the default theme just to give it a test run before I added it to others, but it’s not working properly. I’ve tried it myself, and so have users.

This is what ends up happening:


Thread test is here.

1 Like

What other components/plugins are you using? A conflict is usually the culprit in these situations, as that component is working fine on both of my Discourse instances.

Also, I am looking forward to NaNoWriMo this year! :wink:

1 Like

Nothing fancy. Just these, no plugins.

(The Vincent one is straight css, only on the Vincent theme, not default.)

First year we’ll have nano on discourse. Can’t WAIT.

1 Like

I’m using Vincent on one of my sites as well. It’s a great theme, though you may have to fix the CSS in a few places, as the theme hasn’t been updated for the changes in Discourse 2.3. (I just added a theme component containing the CSS fixes … easy peasy.)

I’m using all of the components you are except for the Staff Color Fix one.

Are you using any unusual plugins?

Nope, no plugins at all, just SSO

Okay, so I was BRIEFLY able to replicate what you were seeing by installing the component on a Discourse instance which didn’t have it installed previously. When I used the component for the first time, I got the same behavior you saw (images way off to the right side).

HOWEVER, the problem resolved itself after I did one small thing: I added line breaks between the image URIs. When I saved the message, within a moment or two, the engine re-rendered the images in tile format as expected.

So, I changed this:

![PNG|690x376](upload://tkDa9A71XGWBECPZ8O4NJ7EVU0o.jpeg) ![PNG|690x375](upload://qF63DV2mw5jrFWvYleWclebsDMo.jpeg) ![PNG|690x376](upload://8xiyNyKpSqdDOfh4mxMHgy0Bzkh.jpeg) 

</div>

To this:

<div data-theme-tiles="1">

![PNG|690x376](upload://tkDa9A71XGWBECPZ8O4NJ7EVU0o.jpeg) 
![PNG|690x375](upload://qF63DV2mw5jrFWvYleWclebsDMo.jpeg) 
![PNG|690x376](upload://8xiyNyKpSqdDOfh4mxMHgy0Bzkh.jpeg) 

</div>

Interestingly, after it worked once, it no longer seems to matter whether there are line breaks between the image URLs :face_with_raised_eyebrow:

If you want to test it out on either of my sites, just send me a message and I’ll send you links (one is non-public rn) :sunglasses:

1 Like

Okay, after a lot of experimentation and work with @cjk77 on his own installation, we’ve figured out we’re bumping up against the max image size limitations. It doesn’t handle that gracefully, so instead of just failing, it does some weird reformatting on the final product. IF you post an image that’s too small you may get this:


All images used were under the resize limit. Image of the exact limit don’t render at all.

3 Likes

I have this issue also. This is due to the size of the image? Should they be enlarged and reuploaded?

Edit: that fixed it.

1 Like

Yes, based on my experiments the component won’t work on images smaller than the max limit. It has to do with the way oneboxing works, I believe.

1 Like