Topic List Previews (legacy)

What alternative? You can’t compare it directly with plugin settings unfortunately.

I’m pretty sure it was a text field when you first released the TC, you mentioned you could switch it back here Topic List Previews

3 Likes

Oh I could revert it to text but that defeats the option of having a nice quick verified list.

But you are right I could switch it temporarily.

3 Likes

Thank you Robert for your hard work to make it compatible with the new theme component manager. That’s outstanding !

3 Likes

Just coming back to report that my problem is solved.
I simply deactivated the plugin and tried the theme component version.
It seems to be working neat! I can also pick my existing tags now.

Thank you for your hard work.

3 Likes

I have some more feedback on the theme component:

  1. Will you be adding the svg feature for the default thumbnail that is in the topic preview component? I’ve been using an image of an svg which is not great for dark/light themes.

  2. Topics created with the wordpress plugin do not have thumbnails, nor can one be selected (see this category), I’m guessing it’s related to this, but it did work with TLP plugin, so maybe it’s a core issue now.

  3. Bugs with other plugins - FYI the locations plugin is currently breaking thumbnails on desktop (this just started with the latest updated today) and the events plugin is breaking thumbnails on mobile, so these need to be disabled for the component to work currently. I’ll report these bugs appropriately later, I just wanted to make everyone aware since it took me a while to figure this out.

2 Likes

No plans to at this stage. I believe supporting a default thumbnail is an important differentiation to the SVG option. Perhaps I could offer both at some stage.

Yeah it’s likely to be a core issue.

Thanks for the report. That’s interesting!

3 Likes

Hope it is okay to bug report.

The featured image on the top sometimes updates and shows a newly tagged image but sometimes it doesn’t. I am still using the older plugin. Is it recommended to use the new theme component and sidecar plugin?

2 Likes

@merefield So we’re in the ‘5 day upgrade window’ now if I’m not mistaken. Is TLP ready to roll?

1 Like

Sorry, I’m working on another plugin atm. It was just days ago but not had chance to recheck. I’d only upgrade it now if you can check the upgrade first in a staging environment. I’ll get to it soon. I’ll extend the support period in compensation.

3 Likes

It’s now safe to update Topic List Previews plugin. I’ve brought it up-to-date with latest core codebase. Featured Images is working correctly.

https://github.com/paviliondev/discourse-topic-previews/pull/155

I will be supporting the build over the next 5 days in case there are any additional breaking changes from core.

Known issue: on Desktop Firefox, the masonry (tiles) layout is glitching slightly on load. This doesn’t affect Chrome, Safari or mobile. I will look at this a bit more next week. If you really hate it, try the TC.

3 Likes

Seeing the same problem with the latest update to the old plugin. Haven’t tried the theme component yet.

2 Likes

You going to have to provide detailed step by step instructions (STRs) to allow me to reproduce the problem.

1 Like

I updated discourse and also TLP.
Discourse is at 75b1298e99
TLP is at 97c56af

When I tag a image with “featured” tag (restricted to only staff members, so that only staff can tag but others can see this tag) it doesn’t get populated on the featured image row at the top.

If you see here - Topics tagged featured there are some images which are not shown int he top row. I have also tried rebaking the posts but it doesn’t help/

When you tag them, there is momentary flicker at the top row suggesting that something is reloaded but the image thumbnail don’t show up.

Hope this is helpful.

2 Likes

Unfortunately haven’t found any way to easily replicate the problem as of yet. The only commonality found so far is that it only seems to effect topics added within the last month. Works fine with older topics, but with anything recent, tagging featured fails to display at the top. To clarify the problem was also in the version prior to the latest update to the plugin, and started after the May updates to core. Thumbnails are generating for category views for the effected topics, the only thing not working is the featured tagging.

4 Likes

Can you please screenshot your settings, just the few that relate to Featured Images?

Sure here it is

2 Likes

Not convinced this is a bug yet. It is probably behaving as intended.

So via the settings you are limiting it via the setting topic_list_featured_images_count which is 6. All images are appearing. The order of the query is set by when things were tagged (setting topic_list_featured_order), so older will appear first I believe. That’s why no newer images are appearing, I think.

Increase this number: topic_list_featured_images_count

Or change the order criterium.

(nice looking art btw!)

1 Like

I have tagged new images too but they didn’t show up except for the first one in the screenshot. I’ll increase the numbers and check.

Thanks for appreciating the art, our users are really great artists :slight_smile:

2 Likes

No I increased the number to 12 but I still can’t see many of the recently tagged artworks. these artworks are also not old. check this screenshot, you can see the featured image as well as the top row beyond the initial 6

1 Like