Transition problem

I was installing forum on a remote server, then added my main site to the server via CPanel for remote servers so moved from regular NameCheap hosting to a remote server, then I got the forum site down and I can’t even run the ./launcher rebuild app command or uninstall. It writes an error that there is no file *.yml or can not access, by checking ls -al does not find a file with app.yml or another name and says that the ports are not open.

I don’t believe CPanel is supported.


Well, they should work on the same server, and not conflict I now on that domain name simply: Index of /

Good Luck!


I think that cPanel only works for PHP-based stuff. If it had a reverse proxy, you might be able to make it work, but it would be hard. If it did have a reverse proxy and you knew a lot about how it worked, you could install Discourse on its own server, see how that worked, then change the ports in the app.yml file to whatever the reverse proxy would point to and then you could conceivably copy that app.yml to the cPanel server and then it might work.

But if all of that doesn’t make complete sense, you’ll be better of just sticking with installing Discourse on its own server with a standard install.

okay, i buy another VPS Server
OC: Ubuntu-20.04-amd64
Port speed: 250 Mbps
Disk space: 20 GBand it says this, I need to increase the RAM?

WARNING: Discourse requires at least 2GB of swap when running with 2GB of RAM
or less. This system does not appear to have sufficient swap space.

Without sufficient swap space, your site may not work properly, and future
upgrades of Discourse may not complete successfully.

Ctrl+C to exit or wait 5 seconds to have a 2GB swapfile created.
install: cannot remove '/swapfile': Operation not permitted
fallocate: fallocate failed: Text file busy
mkswap: error: /swapfile is mounted; will not make swapspace
swapon: /swapfile: swapon failed: Device or resource busy
/swapfile       swap    swap    auto      0       0
vm.swappiness = 10
Failed to create swap: are you root? Are you running on real hardware, or a fully virtualized server?

20 gb if disk space is likely to be too little.

The error says that it failed roku at up swap space. Are you running as root?

It would appear that you don’t have rights to create swap for some reason. Either you’re not running as user root, or you don’t have a proper vm that gives you the control you need.

  • 2 CPU cores
  • 2 GB RAM
  • 40 GB SSD RAID 10
  • 1000 GB bandwidth

it’s nice VPS server?

This is the bare minimum now imho. Better to have 4GB. Even with 2GB swap, online updates with only 2 + 2 are painful!

You also need to have Ubuntu 22.x as there are recent new dependencies on this.

Are you running as root?

Can you run docker?

i buy

  • CPU 4 Cores
  • RAM 6 GB
  • Disk Space 120 GB SSD RAID 10

and i install docker, git, clone repository and i run a ./discourse-setup и у меня пишет следующее

Checking your domain name . . .

WARNING: Port 443 of computer does not appear to be accessible using hostname:

WARNING: Connection to (port 80) also fails.

This suggests that resolves to some IP address that does not reach this

machine where you are installing discourse.

The first thing to do is confirm that resolves to the IP address of this server.

You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue.

A web search for "open ports YOUR CLOUD SERVICE" might help.

This tool is designed only for the most standard installations. If you cannot resolve

the issue above, you will need to edit containers/app.yml yourself and then type

./launcher rebuild app

How do I fix it because I can’t even delete it all from another VPS or what can I do?

If you ssh to that host name, so you get to the correct vm?

well I’m completely connected to the new vm, I already had discourse on this subdomain.
if I’m looking at it right.

The name must resolve to your vm ip address.

$ dig +short

Is the new vm

no my new server

You need to update the dns so that it points to the new server.

That’s what this was trying to tell you

$ dig +short

it’s command that I update the ip or should I update the ip in my domain service?

That’s how to check. You need to update it at wherever the dns is. (name cheap, perhaps)

DNS is always the problem.

1 Like