Translated strings cannot be customized


  1. I overrode the English “You earned…” with “You discovered…”
  2. I changed the default language to French
  3. When looking up “gagné” I find the “Vous avez gagné…” string matching 1.
  4. I try to customize this text, but I get the English version instead.

What should happen

At 3., I can customize the French version.
At 4., I get the translated string to customize, not the original English.

How to fix it

I guess this is quite some work since it requires to be able to overload all translated strings for all languages. Another option would be to change the original translation for this particular case, since it gives a more game-like feeling than “earning”. But in the end it should be useful to be able to override any translated strings in a non-English language since if you want to do this for English, you also probably want to do it with other languages.

Would a “translation plugin override” be doable?

1 Like