Translation missing in english locale?


(Christoph) #1

I made some minor changes to the body (not the subject) of the invite mailer template (admin/customize/email_templates/invite_mailer) and saved them. Then I clicked on “revert changes”. Now the subject line of the template says

translation missing: en.invite_mailer.subject_template

My site locale is English (and so is my user locale, if that matters). I’m on v2.0.0.beta4 +170

Edit: I can’t seem to reproduce this. Not sure what happened. I can’t reproduce this on my other discourse instance which is on v2.0.0.beta4 +104 :man_shrugging:


Unable to revert changes under Admin > Text Content
Unable to revert changes under Admin > Text Content
(Gerhard Schlager) #2

I’ve noticed that bug too. Entering a valid translation and reverting it one more time usually fixes it.

I tried fixing it in the past, but my solution had other side effects. It’s still on my list of things I’d like to fix.


(Wolftune) #3

I’m seeing the same bug in v2.0.0.beta5 +6

I’m not able to fix it or find a workaround. I’m seeing this for all customized text. “Revert” always turns it into a translation-missing message. So, I’m finding no simple way to revert to default text (since reversion isn’t working, I’m not even clear whether it’s supposed to return to default text versus to the previously-saved edition).


(Christoph) #4

“Revert” always reverts to default (or rather: it should).


(Wolftune) #5

Thanks, that’s what I’d expect (the other behavior I guessed about could be called “undo” instead of “revert” if it ever were to exist).

I assume as a workaround there’s some way to access / look-up the default for any entry and be able to just paste that in until the bug is fixed…?


(Gerhard Schlager) #6

Restarting the Docker container should work and remove the cached translation errors.


#7

Hi Guys,

When I try to revert a change on a text field, I get an error saying “translation missing: en.js.trust_level”

image

If I click on “Save”, it saves “translation missing: en.js.trust_level.”

Not really big deal.


(Arpit Jalan) #8

Is this happening for all the translations or is it specific to js.trust_level? Also what’s your site locale?


#9

Our site is in english and it is happening on all settings.


(Arpit Jalan) #10

Are you on latest Discourse version? If not can you update your site from server console:

cd /var/discourse
./launcher rebuild app

I can’t repro this issue on my local dev environment.


#11

Tried that already :slight_smile:


(Arpit Jalan) #12

Are you seeing any relevant errors in /logs? Also, when you edit the field to “Trust Level” and click Save Changes, are the changes getting saved correctly?


#13

Hum I can’t find interesting logs. Here is a short screen capture


(Anders Thengs Kristensen) #14

This happened to as well. If you just revert it and refresh the page it should go back to the default.


(Simon Cossar) #15

I assume this is related:

I can reproduce this on my hosted Discourse forum. I’ve never seen the issue in my development environment.