Trial period limitations - sending an email invite?

Hi… im 6 days into the trial period and i am loving the software… and i intend to go for the paid version when the trial ends. I havent paid for it yet, as im using this free time to build it.
I have sent an ‘invite’ to another one of my own email address’ purely to test and see the way it works etc, but when i click on the link in the email it informs me that the invitation cannot be redeemed, and im wondering if this is because im not yet on a paid version or whether its down to a setting that i have overlooked somewhere. thanks

1 Like

Hello MW welcome to Meta :discourse: :tada:

The trial gives you Discourse ‘as is’ but with hosting tier restrictions eg plugins. So that’s not the issue.

Silly question but did you change the expiry date/time for the invite? I’ve done something before where I sent an invite but Discourse sets the expiry time the same as real time.


Hi onderj

thanks for the reply and advice, and i hadn’t noticed the fact that the default time is in real time until you mentioned it, so i changed it to 1 day, and the 2 days later on the calendar and the same response happens both times, still not valid invite, so its strange yes - not sure what else it could be

Hi @M_W :wave: welcome to Meta :slight_smile:

Please make sure email addresses are valid.

Also, might want to check the invite settings - go to Admin - settings and type “invite” in the search filter field (some settings may be more limited for free trial).


Hi Lillian

the emails are being sent out and received to my inbox’ with no issues there so they are valid, and the check boxes on your shot, are the same as mine - so im still no closer to resolving it sadly. Its very late where i am, so tomorrow il reach out to discourse through an email and see if we can get any clarification. thanks for your message

1 Like

Sorry if my screenshot wasn’t clear - it is only the meant to show how to get to the invite settings - I didn’t show the right pane with the actual settings because they are likely checked differently than yours are (I was using a Meta admin screenshot). The settings are on the right side of that column and there are a few there related to invites that may apply to your case. I will have a look at this issue in more detail but I could not reproduce on my test instance.

Here is the documentation for sending invites.


Just to round this out, after a little extra conversation in a PM, it was down to redeeming the invitation in the same window as a current account session. Using a private browser window instead sorted everything out. :raised_hands: