Trust level 4 users cannot set topic timers anymore

(rizka) #1

When we upgraded to 1.9 the trust level 4 users seem to have lost their ability to set timers for topics. So they cannot auto-close topics or close them temporarily. They can close them in a regular manner, though.


This must be a bug or a regression. It cannot be intentional, right?

(We are on 1.9.1)

(Jeff Atwood) #2

Possibly, what do you think @tgxworld?

(Joshua Rosenfeld) #4

Topic timers are staff only at the moment: see How to create a Timed Topic. I fully support giving TL4 users topic timer permissions, but that’d be a new #feature, not a #bug.

(rizka) #5

Trust level 4 had the feature in 1.8. No doubt about it.

(Joshua Rosenfeld) #6

Did it work though? When I tested this back in August the timer didn’t actually do anything when it was triggered:

(rizka) #7

We never experienced any problems. Here is a topic that was scheduled to close in 60 minutes by a TL4 user:

(Joshua Rosenfeld) #8

Consider me confused then. Moving this back to #bug. I’ll be quiet now and let the real engineer (@tgxworld) look at this when he comes in :grimacing:.

(Alan Tan) #9

@jomaxro Yea topic timers are supposed to be available to admins and users with trust level 4 or higher. Do you recall why we restricted it to staff only?

(Joshua Rosenfeld) #10

It came from this topic: How to create a Timed Topic. Topic timers were not working for TL4 users when I tested it (timers could be set but nothing would happen when they triggered), so Jeff said to disable it unless it was an easy fix.

(Alan Tan) #11

Ah icic. I’ll have a look then :slight_smile:

(Alan Tan) #13

Can you try reproducing this again? I tried locally but the timers were working fine for me. Thank you!

In the mean time, I’ve reverted

(Joshua Rosenfeld) #16

I can confirm that auto-close, close temporarily, auto-open, open temporarily, schedule publishing, and remind me all work for a TL4 user on try.

However, Auto-Delete does not appear to work.


TL4 users cannot delete topics anyway, couldn’t you just remove auto delete for TL4 since that is the only problem.

(cpradio) #18

This is now fixed by @zogstrip

(Régis Hanol) #19