Turn off "Title seems unclear, is it a complete sentence?"


(Michael Dunn) #1

I’m trying to post a message to my discourse server using the API. The title of the post I’m trying to make is
[2017-09-21] events.linear_spotlight_attribution_rate.events.ga_landing_content_type_bucketed.Doctor.Media..w..Lists.

Discourse responds with a 422 error, saying “Title seems unclear, is it a complete sentence?”

I would like to turn off whatever is checking the title. Having read other topics on this issue, I have allowed uppercase posts and I’ve set the min title entropy to 0 and the server continues to throw the error. I also turned off prettyifying of titles.

Trying to post the message via the UI results in the same error being thrown.

Any idea how to actually turn this off?


(Jay Pfaffman) #3

title max word length is what you’re looking for. It turns out, that mostly if someone types a word that’s more than 30 characters, they shouldn’t be allowed to post anything. :slight_smile:


(Michael Dunn) #4

Thanks, Jay; that solved it!