Unable to enable the old welcome message


(Anders Thengs Kristensen) #1

I have disabled the “discourse narrative bot enabled”, as I would prefer to keep the old welcome message.
The problem is that the only setting mentioning a welcome message is “disable discourse narrative bot welcome post”. And regardless of whether it is enabled or disabled, there is no welcome message sent to new users.

Could anyone inform me how I can re-enable the old welcome message?


(Daniela) #2

Search for send welcome message , it should be in Settings > Other


(Christoph) #3

No, I thought so too, but just checked and it’s no longer there


(Daniela) #4

So this is probably a bug. When you disable the narrative bot you should be able to set again the welcome message

cc @tgxworld ?


(Alan Tan) #5

When you disable the bot, the send welcome message site setting is auto enabled again. I’ll have a look to see if that is still the case.


(Jeff Atwood) #6

The old copy still should come from the bot, though. We want one code path here.


(Alan Tan) #8

Fixed in

The bot basically has a new SiteSetting which allows you to configure which type of welcome post you would like to send.


Discourse Narrative Bot Beta Feedback
(Jeff Atwood) #9

We should also close the welcome message in the “quick start guide” case as we want to have very clear signaling that the user should not respond to it.

(arguably we should also do this if bot replies are disabled too.)

(edit: I have also removed the invitation to reply from the existing beta version in anticipation.)


(Alan Tan) #11

Fixed in


(Alan Tan) #12