Unable to enter my discourse site


(Sarah McCrum) #1

For the last two days when I try to get into my discourse site this is the message I get: “I’m sorry, your requested action is not allowed. If you have any questions, please contact the server administrator.”

From time to time it works for a little while and then reverts back to this message.

The site is connect.gamechangersgo.com

There doesn’t appear to be anything obvious wrong at the digital ocean end.


(Jeff Atwood) #2

Can you post a screenshot? I don’t think this message exists in Discourse so it so coming from elsewhere.


(Sarah McCrum) #3


#4

Works for me, i’m redirected to : Gamechangers
And I have a classic Discourse (I didn’t try to create an account tho)

You might have messed things up on your DNS providers or your app.yml file if you can’t access it


(Sarah McCrum) #5

I just tried that link that you were redirected to and this is the message I got: Not Found

The requested URL /login was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

What do I need to do to actually solve it?


(Sarah McCrum) #6

I cleared my browsing history and it’s now working. but I’m not sure why it’s not working for people I’ve invited as users though. I’ll see what message they are receiving.


(Jay Pfaffman) #7

I’d recommend turning on https to reduce the likelihood that problems are not inserted by some internet service between your Discourse and your users.


(Sarah McCrum) #8

I’ve tested it myself and it seems to be working now, also for inviting new users. I hope it will continue!


(Sarah McCrum) #9

Needing some more help on this one. The only way I’ve found to solve the problem is to clear browsing data. I had one of my clients who also got the same message and when she cleared her browsing data it worked again. I’ve had to do it several times. I don’t known enough to understand what’s going wrong and how to resolve it.


(Jeff Atwood) #10

There’s something seriously wrong with your DNS / hosting config; it’s not a Discourse issue per se.

I don’t think we can help you much on this.


(Sarah McCrum) #11

Thanks for clarifying that.


(Jay Pfaffman) #12

Turns out that the problem was that there were two A records for the forum, so some of the time the right address would be returned, but not others.


(Jeff Atwood) #13