Unexpected error 500 that never seen before (missing S3 bucket name)

Hi! I’m running a Discourse (docker) in DigitalOcean for the last 3 years without too many problems.

Today, after changing a few settings related to the size of the images, the whole site turned into an error 500, showing this message

Note: sorry, I can only see the spanish version, I don’t know how to get the english one in this situation.

I tried rebuilding the app without luck. Nothing clear from the logs neither, at least for me.

Since I never have seen this error before, I will drop just a few lines of information that could be relevant (or not):

  • Images are in S3. I haven’t touched anything regarding the AWS/S3 config.
  • I’m running the forum with Let’s Encrypt
  • I can enter the app via rails console without problems

I tried doing a search before in the forum but since the message, it’s in spanish I can’t find the version in english :thinking:

Note: maybe is a good idea to include an error code into that message, even when it’s translated, to use is as a reference in the forum later.


Can you load the logs (http://yoursiteurl.com/logs) ?


Yes! I don’t know how I forget it! (I never had this kind of problem in 3 years with Discourse, sorry).

Seems like it is related to S3 :thinking: it’s at least a clue, something where to start debugging

1 Like

Looks like your setting s3_bucket is empty/missing somehow…

Are you running latest Discourse?


No, I updated the forum around 2 months ago or so.

You hit the nail on the head, IDK how it happened :facepalm: this is kind of crazy.
I’m restoring the bucket name from the console and let’s see if works.

1 Like

@Falco it works. I’m ashamed, the lack of practice debugging Discourse blocked me :facepalm: thank you so much for you quick response.

I will update the title now that I know the error.