Update failed - forum not working, says it's up to date

I’ve tried updating the docker manager yesterday but it failed the update. This are the logs:


I tried to restart the update after checking what went wrong. But it said that the docker manager was up to date and there was no more updates available. So I assumed that it still updated (this was my bad assumtion and now I know I shouldn’t have done it)
So today I proceded to update the discourse forum. I got an error (I couldn’t copy it, because the page reloaded - don’t know why, sorry). All I got now is not working forum (the user can only see that there’s an error and that we are fixing it) but in the admin panel, which stayed opened luckly, says that the discourse forum is up to date and there are no more updates available and it should work normaly.
Please help.

1 Like

Have You tried rebuilding?

SSH into your server and

cd /var/discourse
git pull
./launcher rebuild app

I have not. I’ve just discovered a similar thread to mine. But will try that in a few moments and see if it fixes it. Thank you for the fast reply.


If You’re updating after a long time (~4-6 months) then there were some changes made to docker manager that caused the Symptoms that you described. A rebuild is enough to solve those issues. I hope it brings your forum back online.

1 Like

Given how often this pops up, perhaps the /admin/update page should show a warning when a new image is available and a rebuild is required?


I think the notice should be placed on /admin instead of/admin/update to encourage more regular updates.


Yes I have not been able to update the forum since September. That might have been the issue here then. It is a shame there wasn’t any special warning to the docker manager tho. As soon as I rebuild it I will come back with the report. But thank you all for help so far.


It already does. The last bug, where we refactored $redis, was unfortunate since a race between updates made it not possible to use the system to warn this time.

But every other time we use this and it is very explicit about it.


It all works now as intended with everything up to date.
The things that I did is the following:

From this post I copied the suggestion.
After that I have done as you have suggested. It took a few minutes. But everything when smoothly and now works.

Again thank you for your help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.