Update/Rebuild Error Code 1 (3.1.0.beta4 -> 3.3.0.beta3) - Redis port 6379 related?

Good morning everyone, first post here for myself. Been poorly maintaining a DigitalOcean/Discourse server I inherited a few years back, and just reissued by SSL cert and tried to update/rebuild the app, and had the following error reported here.

I, [2024-07-04T10:58:00.012668 #1]  INFO -- : > exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf
I, [2024-07-04T10:58:00.017822 #1]  INFO -- : > sleep 10
954:C 04 Jul 2024 10:58:00.044 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
954:C 04 Jul 2024 10:58:00.044 # Redis version=7.0.7, bits=64, commit=00000000, modified=0, pid=954, just started
954:C 04 Jul 2024 10:58:00.044 # Configuration loaded
954:M 04 Jul 2024 10:58:00.045 * monotonic clock: POSIX clock_gettime
954:M 04 Jul 2024 10:58:00.046 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
954:M 04 Jul 2024 10:58:00.046 # Failed listening on port 6379 (TCP), aborting.
I, [2024-07-04T10:58:10.031866 #1]  INFO -- :
I, [2024-07-04T10:58:10.032253 #1]  INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
rake aborted!
Gem::LoadError: can't activate stringio-3.1.1, already activated stringio-3.1.0 (Gem::LoadError)

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 958 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"cd"=>"$home", "tag"=>"migrate", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
bootstrap failed with exit code 1
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

Please see the attached full log.

Tried the rebuild command again with “sudo” because I know what I am doing and I heard that makes anything work… It did not. :rofl:

Please recommend any steps I could take as simply as possible. I am not familiar with all the linux commands, and barely know my way around the discourse software.

Thank you for any assistance on this issue.

Plugin list:

          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discourse/discourse-data-explorer.git
          - git clone https://github.com/iunctis/discourse-formatting-toolbar.git
          - git clone https://github.com/paviliondev/discourse-locations.git
          - git clone https://github.com/paviliondev/discourse-events.git
          - git clone https://github.com/jannolii/discourse-topic-trade-buttons.git
          - git clone https://github.com/discourse/discourse-cakeday.git

I do not have any MAXMIND tags in my app.yml file.

I would first remove the non standard plugins.

1 Like

Thank you, @pfaffman!

After updating and upgrading ubuntu, rebooting the server, running the doctor, and repeated retries, I was planning on trying this next when I saw your reply confirming those suspicions.

Disabled the non-Discourse plugins, and the rebuild was successful. Re-issued SSL certs are now in use, and I can take some time to get it all configured the way we had it.

Appreciate the assistance, and hope to spend more time here and learn more when not under the gun.

It sounds like your setup was installed before Let’s Encrypt; there’s no need to manage certs by hand. I’d probably recommend moving to a new VM (I bet your OS it beyond end of life too?). See Move a Discourse site to another VPS with rsync.


Thank you for that advise as well. It had been set up as an auto-renew config based on the original set up around 5 years ago, but I’ve just been keeping it on life support the hard way it seems.

I’ll do some research, and will take this advice into consideration. Thanks again, Jay.

1 Like