Upgrade button does not refresh until forced

Hi everyone,

I’ve noticed that for the last, well, I don’t know how long now, but for a couple of months at least whenever I upgrade via the admin panel, the page doesn’t refresh correctly and it still shows me the blue Upgrade button.


If I do a CTRL+F5 I then get a corrected view:

Browser is Firefox on a Windows PC:

I’ve not tried any other browser combinations.

1 Like

I tried today on Chrome browser and have the same issues.

Here’s how I started off, 4 commits ready to be installed on the docker_manager

Then when they’ve finished and I come back to the Versions tab, it says last updated 13hrs ago for some reason but the upgrade button is still clickable (I’ve not dared click on it again!)

If I CTRL+F5 to refresh my browser then it changes to “Up to date”:

I then install the 75x commits for Discourse.

When finished, I click on the Versions link again:

And the blue Upgrade button is still clickable:

Again, a CTRL+F5 refresh sorts it out.

This time I used Chrome v81.0.x on Windows PC.

It never used to do this, but it has been doing it for months now, I just forget how many months :slight_smile:

1 Like

I am unable to repro this. When I update a plugin, after returning to repo list by clicking versions each repo refreshes one at a time. I never see
without having new commits.

Chrome 85, Windows.

1 Like

Does it say “Up to date” on yours then @jomaxro ? Rather than offering you the blue button again?

My first post on this thread was with Firefox, my second post was with Chrome.

@Stephen 's (now deleted) post confirmed he was able to repro on his Mac too.

Correct. It shows “Up to date” only, no button, no remote version, no last updated.

To be clear, not saying there isn’t a bug here, just that I cannot repro it on my specific setup.