Upgraded but admin page says out of date


(Multicam) #1

Hi there,

I just received the email for the upgrade to 1.3.0.beta8.

Followed the procedure, and now the admin panel still shows that an upgrade is available, but the upgrade page states that it’s all OK. See attached screenshots:

Admin Page

Upgrade Page


A red smile means upgrade?
(Jeff Atwood) #2

Did the upgrade succeed? Does not look like it did.

Does hard refreshing your admin page help?


(Multicam) #3

I agree it didn’t succeed, but the upgrade page doesn’t allow the upgrade claiming it’s all up to date – 6eec354
Is there a way to force Discourse to upgrade again?

And no refreshing the admin page didn’t help.

Cheers


(Jeff Atwood) #4

You will need to upgrade via SSH and command line.

cd /var/discourse
git pull
./launcher rebuild app

(Multicam) #5

I’ve just done that.
The process went with no problem.

But I still got the same issue.

I have logged out and back in. No luck (red meh)


(Jeff Atwood) #6

Bizarre, no idea, try rebooting the server?


(Multicam) #7

UPDATE :: a new update notification popped up and went through nicely – Discourse has updated to 1.3.0beta7+95 (was beta7+93) before – still red meh

I’ll try rebooting the server


(Multicam) #8

Update :: rebooting the server killed the docker

Device “docker0” does not exist.
Cannot connect to the docker daemon - verify it is running and you have access

Being a noob doesn’t’ help :: fixed by restarting the docker service…

The update didn’t take so – still 1.3.0beta7+96 now but no beta8


(Alex Harrington) #9

I’m seeing something similar.

Tried to upgrade but the Adsense plugin broke the upgrade, so after removing it from app.yaml, I did

cd /var/discourse
git pull
./launcher rebuild app

Admin page then said that I was on v1.3.0.beta7 +102 and that beta8 was available. Clicking on the upgrade link took me to a page saying that everything was up to date.

A while later I got another upgrade notification and the upgrade ran successfully via the webpage, and I’m now running v1.3.0.beta7 +103 and it still says beta8 is available and I’m not on the latest version?


(Sam) #10

I’m seeing this issue on my test site, too.

This commit: Version bump to v1.3.0.beta8 · discourse/discourse@121a8ba · GitHub doesn’t appear in the master branch I check before upgrading. I’m thinking that’s the issue, but also I’m not hugely familiar with git.


(Adam Capriola) #11

Chalk another one up. I git pulled both last evening and this afternoon but see this:


(Scott Pruett) #12

Same here.

Admin page says I need to upgrade, but the upgrade page / docker manager says I’m up to date.


(Clay Heaton) #13

Ditto. I’ve tried multiple times and it seems to have taken. In fact, the zebra striping is gone, so I sort of assumed that the upgrade took. I’ve had the problem on both Discourse instances that I manage. It told me that the upgrades were successful.


(Kane York) #14

@neil this topic is your fault - you bumped the beta branch to beta8 but didn’t bump the master branch.


(Omni) #15

Speculating on what could have caused such a problem is useful. However, pointing the finger of blame is uncalled for and unproductive. What matters most is that this problem needs a solution.

I can also verify that this problem exists, as my website is facing the same issue.
I’ve performed an upgrade three times today and am still locked in beta7.

http://puu.sh/hL0rt/85d775ee60.png


(Dean Taylor) #16



(Jeff Atwood) #17

Yes, this is our error! @neil is creating a new beta release today that works properly.


(Stephen) #18

Excellent, can we all have a special badge as survivors of the phantom beta 8?


(Jeff Atwood) #19

jedi mind trick hand gesture

there was no beta 8, I think you are mistaken.


(Stephen) #20

It’s edits like those that make live updates the best thing ever.