Upgrade path for very old versions of discourse?


(Peter Grace) #1

I am running 0.9.8.11, non-dockerized. I’d like to jump to using the docker container to facilitate smoother upgrades in the future, but I don’t see mentions of how I might import the old database and migrate it to the latest needed version. Is there a way to handle this in a somewhat-clean manner? Can anyone direct me to some documentation, if I missed this topic being covered elsewhere?


(Sam Saffron) #2

The simplest way is to upgrade Discourse to a version with built in backup restore. Then backup your site, create a new site using the new guide and restore in to it.

Pretty sure there should be a topic somewhere, let me know how you go.


(Peter Grace) #3

Sorry I never replied to this; I was able to upgrade to a version that had viable backup and then restored that backup in a fresh docker instance and everything worked just fine.


(Régis Hanol) #4