Upgrade via UI is failing to initiate, simply resets

I have a vanilla installation and upgrade weekly around 09:00 UTC Saturdays via the admin UI

This week, the upgrade called for a docker upgrade. Initiating this gives an indication the upgrade is happening, but no processes are shown. The screen stays blank. Checking the process window shows no significant activity (you normally see the upgrade tearing through its steps).

After a few minutes the upgrade UI shows that the upgrade is still required, ie the interface is reset and nothing has happened. I’ve tried this three times. I’m away from the SSH keys so can only run upgrades through the admin UI until the new year.

I’ve just performed an upgrade of the docker manager for my self hosted site and it completed successfully, so I’m afraid I can’t repro this bug.

Normally an update from the command line would be recommended in this situation, so it’s unfortunate you don’t currently have access. If you’re on Digital Ocean they also have an ‘Access Console’ option from the web interface, just in case that may be a possible alternative?


Hello, I also have the same situation (

There was a be base image recently. I recommend a command line rebuild.

You can share the commit if your current forum or the url.

1 Like

So I’ll wait until I can get into the shell in January, but the bug is that the UI is not behaving as expected.

If I see this screen and click through, it ought to work:

If I need to use the terminal and do a manual upgrade, it ought to tell me that instead…

Historically, Docker upgrades more often than not had to be done manually. But they seem to have worked very well through the admin UI for the past year or so.


1 Like

Maybe next time…

To enable the Droplet Console, log in to your Droplet as root or as a user with sudo access


You may be running an os that needs to be upgraded.


Thanks for that pointer. It’s possible. I’ll check in the new year & report back here.