Upload avatar failed, save changes disabled

when i upload custom picture, the save changes button disabled. the browser console show an error message. How should I handle this?




I don’t see the exact same error, but I do consistently get an error when I try to upload a custom picture here on Meta, perhaps this is also related. I’ve tried multiple different files:

Screenshot 2023-03-10 at 3.20.43 PM


I’m having exactly the same problem on my self-hosted Discourse, and the search engine brings me here.
The uploading progress is 100% completed but the save btn is gray, and one js error appears in the browser dev tool console.

1 Like

I’m having the same problem, the image uploaded successfully but stuck at 100% in upload and unable to save changes. Even after I reinstalled the server and followed the tutorial to install Discourse, the problem is still recurring.

1 Like

We have the same problem on our forum after a recent update. I think this bug was introduced in this commit three days ago


Dear Discourse Support Team,

I am writing to request technical support regarding an issue that we have encountered on our Discourse forum. We have identified that our users are unable to upload new profile pictures due to a technical problem. Despite our efforts to resolve the issue, users report that the “Save” button is not being allowed even when the upload status is at 100%, which prevents the process from being completed.

As an administrator, I have personally tested this issue and can confirm that the problem persists. Additionally, we have noted that previously uploaded profile pictures are still able to be saved without issue. I have also reviewed the post Unable to upload profile picture but did not find a solution applicable to our case. It is important to note that we are not using S3.

We kindly request your assistance in resolving this issue. Please let us know if you require any further information or if you have any updates on this issue.

Thank you for your attention to this matter.


The latest set of commits hasn’t resolved this bug.

1 Like

Can confirm we’re having the same issue

Thanks for the reports everyone. Someone has been assigned to look into the issue and will hopefully have a fix shortly. :+1:

1 Like

Sorry for the disruption everyone! This is now fixed in tests-passed, and has been rolled out to affected sites on our managed hosting.

Self-hosted forums can update by visiting /admin/upgrade.


I can confirm it works now on my self-hosted site. Thanks.


This topic was automatically closed after 20 hours. New replies are no longer allowed.