Uploaded images broken in table

Hi,

I think it’s a new bug, in a table, when you upload an image the | separating the name of the image and the size works as a new column and breaks the table:

|--|--|
| ![image|50x50](upload://ijWWnisipK7oMJDZL6aPgKIBrzM.png) | ![image|70x50](upload://u8KY4PwRpBSmxvxcqIekquhdHtm.png) |
Table Heading
![image 50x50](upload://ijWWnisipK7oMJDZL6aPgKIBrzM.png)

It’s working for me

Table Heading
flag flag
| Table |Heading  |
|--|--|
| ![flag](upload://rOmWGlMmU2RCqPyBvckbUnDp5wD.png) | ![flag](upload://rOmWGlMmU2RCqPyBvckbUnDp5wD.png) |
Table Heading
baymax-yes baymax-no
| Table |Heading  |
|--|--|
|![baymax-yes](upload://jQhyeBPjJcxLeN23knyhD6zCWha.gif)   | ![baymax-no](upload://6BWNZiwP8GVOjkbIARlnd6cvlPY.gif)  |

The problem is that markdown tables do not support the images size inside the image syntax so you need to use something like:

|Table |Heading|
|---|---|
| ![image](upload://ijWWnisipK7oMJDZL6aPgKIBrzM.png) | ![image](upload://u8KY4PwRpBSmxvxcqIekquhdHtm.png) |
Table Heading
image image

instead of

|Table |Heading|
|---|---|
| ![image|50x50](upload://ijWWnisipK7oMJDZL6aPgKIBrzM.png) | ![image|70x50](upload://u8KY4PwRpBSmxvxcqIekquhdHtm.png) |

PS. You can still use the HTML table if you need to specify the image size.

4 Likes

By default uploaded images add the size details so I thought it might be something to look at, but it’s totally fine by me, easy to go around it!

1 Like

You can also escape the vertical line inside the table:

Table Heading
flag flag
|--|--|
| ![flag\|50x50](upload://rOmWGlMmU2RCqPyBvckbUnDp5wD.png) | ![flag\|70x70](upload://rOmWGlMmU2RCqPyBvckbUnDp5wD.png) |
1 Like

Duplicate of Pictures don't upload well into tables because of the straight bar symbol

3 Likes