Uppy S3 multipart direct upload to DigitalOcean Spaces

Hello,

Yesterday I tried to enable the direct s3 upload (A new era for file uploads in Discourse) on DigitalOcean Spaces. I seted up a new test instance for this.

  1. Enabled the enable_direct_s3_uploads hidden site settings.
  2. Run rake s3:ensure_cors_rules
  3. I tried to set up the CORS on DO Spaces on Spaces settings page however it seems to not support ExposeHeaders so I could not add ETag to it. Which is broke the upload process.
  4. I found a solution for this. With s3cmd I could upload CORS configuration file which could contains ExposeHeaders too.
  5. After I uploaded the CORS config file to the bucket the multipart direct upload works fine.

So it seems to work but I don’t know how safe to use like this on DO Spaces. Does anyone have any long-term experience with this or any suggestion?

Thank you! :slightly_smiling_face:

4 Likes

Update: After almost 3 months testing on my test site I didn’t notice any issue so a few days ago I activated it on my live site. Seems to works without any problem. :slightly_smiling_face:

2 Likes