User Email preferences being overriden

Update as of 2021-12-29T07:36:00Z:

@RGJ It has reverted my settings again to always send.

Are there any logs I can check to see what is changing my settings? Thank you!


Got it. Thanks! Just upgraded to 2.8.0.beta10. Hopefully, that fixes things.

Are you able to repro this issue on meta?

Testing now. Can anyone please DM me to test? :sweat_smile: Thank you!

Here are my current settings here in Meta:

1 Like

Just sent you a DM… @rkda

1 Like

Thanks @sam! I’ve received two DMs (one from @JammyDodger) and my settings have not been overridden. I’m no closer to getting to the bottom of this mystery🤔

Not sure if it makes any difference but those in our Discourse instance, those DMs are from staged users. They’re posted via email but it shouldn’t make a difference AFAIK.

Is there a Discourse setting to override email preferences? I might have inadvertently enabled it somehow. That’s the only explanation that makes sense right now :man_facepalming:

1 Like

Does this override your email settings as well?

Like if you set email notifications to “never” will activity in a topic you’re Watching ignore that setting?

Been wracking my brains as my email settings kept getting ignored and I can’t figure out why. I kept getting emailed my group messages no matter what my email settings are. I’m suspecting it has something to do with the notification level settings for groups I’m part of.

If you set your Email me when I am quoted, replied to, my @username is mentioned, or when there is new activity in my watched categories, tags or topics and Email me when I am sent a personal message settings to ‘never’ then you should not be receiving emails for notifications.

There is also the Activity Summary box: When I don’t visit here, send me an email summary of popular topics and replies that may be worth double-checking, but that’s for the Digest/Summary email, not Group Messages.

1 Like

CleanShot 2022-04-21 at 18.54.41

Here are my preferred settings (on a self-hosted forum) :point_up_2: but it always gets reverted to always as soon as someone sends me a group message. Haven’t reproduced it on meta though as I’ve only thought of the possible group messages connection today and I’m not part of any group here AFAIK

1 Like

Let me slide these over to the original topic and flip it to #support while we work out what’s going on. :+1:


@rkda Can you give any more detail about your set-up? Any plugins or theme components that may be unusual or connected to messaging or groups?

I’m trying to replicate it on my test site, but no luck so far. Does it happen with messages from only a certain group, or is it all groups?

1 Like

Thanks! Here are plugins I’ve installed.

https://github.com/discourse/docker_manager.git
https://github.com/discourse/discourse-docs.git
https://github.com/discourse/discourse-chat-integration.git
https://github.com/discourse/discourse-checklist.git
https://github.com/discourse/discourse-feature-voting.git
https://github.com/discourse/discourse-calendar.git
https://github.com/discourse/discourse-saved-searches.git
https://github.com/discourse/discourse-solved.git
https://github.com/discourse/discourse-assign.git
https://github.com/discourse/discourse-reactions.git
https://github.com/paviliondev/discourse-tickets.git
https://github.com/discourse/discourse-cakeday.git
https://github.com/discourse/discourse-whos-online.git
https://github.com/discourse/discourse-data-explorer.git
https://github.com/discourse/discourse-math.git
https://github.com/discourse/discourse-footnote.git
https://github.com/discourse/discourse-shared-edits.git
https://github.com/discourse/discourse-yearly-review.git
https://github.com/discourse/discourse-teambuild.git

And I have the following components installed:

CleanShot 2022-04-21 at 20.02.39

I’m running Discourse 2.9.0.beta4 if that helps. Emails are being sent though mailgun.

Can’t say for sure as I’m only active in two groups (dev, helpdesk) but it happens for both.

And, before I dive into a rabbit hole, you’re definitely saving the page after you change your email preferences? :slight_smile:

1 Like

Yup! Been wrestling with this for a quarter now :laughing:

I posted it here because I was hoping there would be a quick fix :sweat_smile: Or I missed some obvious settings.

Most messages to the group are also sent via email by the way (not sure if this is relevant). We set an incoming email (i.e. helpdesk@company.com) for the group and people without Discourse accounts email to it. We have enable staged users on. We usually reply to those people via email as well. We mostly use the group messages as a mirroring feature for transparency purposes (does that make sense).

If it’s too much trouble on your end then I guess I can live with it. It’s a minor annoyance at worst and it seems to be an edge case that doesn’t seem to affect a lot of users. I’m not sure it would be worth the trouble on your end when you have other more pressing issues so no worries.

1 Like

I thought I’d better check, just in case. :slight_smile:

I’m going to install the Pavilion Tickets plugin on my test site and have a quick run-through with that. I can’t promise I’ll find an answer, but it’s piqued my curiosity enough to try. :slight_smile: :crossed_fingers:

1 Like

Heh.

Thanks and good luck! :four_leaf_clover: :smiley:

Man, it would be so funny if that’s the culprit. We don’t even use that anymore :laughing: It’s disabled but I was too lazy to remove it from my app.yml.

1 Like

Unfortunately, I have had no luck. I set up a group inbox, with email-in and staged users, and it works as expected. There were no extra ‘Urgent!’ settings in the Tickets plugin that did any secret magic either. My email preference has stayed on Never, and refuses to flip.

Sorry I couldn’t be more help. Though if you can think of any other repro steps I could try I’m happy to give it another run-through.

If you have unused plugins you could try cleaning up your app.yml (and rebuilding) and see if that makes a difference?

1 Like

No worries. Thanks for checking it! :smiley:

I have set my group notification level to Tracking (used to be Watching before) and it seems to have worked.

CleanShot 2022-04-22 at 17.26.59

Will come back after a week and report if it sticks :laughing: I don’t know if it makes sense but as long as it works then I’m happy :rofl:

1 Like

My bad. Wasn’t able to come back earlier. It worked for a time but it’s back again :scream:

I wonder if it has something to do with DMs that I posted to Discourse myself via email. If I’m not mistaken, that automatically sets the notification level to “Watching” right? Though I don’t think that should flip email response to Always (or does it?).

I use the web interface most of the time but I do post to Discourse via email a lot. We use Discourse as a group inbox for the team. We have a team email address (i.e. helpdesk@company.org) that automatically forwards to Discourse and where it gets posted as a DM for the team group.

We have Staged users enabled so that replies from external users get posted as well so the rest of the team sees the context of conversations. We usually reply to those users via email as well so we use Discourse as more of a mirroring tool for this use-case (Google Groups can be rather unwieldy and ugly).

I’m not sure if it has anything to do with it but for now I’m resigned to just living with it :laughing:

Ah, so this happened to me yesterday and I can confirm that it’s deliberate…

The supporting tests and comments indicates so

Code:

Tests:

Essentially when we send an email to a group, despite having set “Never” to that option, it will always set it to “Always”. The idea is that if we send an email, we’d want to receive the email response in our email inbox as well.

The sort-of answer here is to just use Discourse to send PMs to groups.

3 Likes

That is a reasonable assumption :sweat_smile: I mainly use it as mirror though so I guess it’s not for my use-case.

Oh, that won’t work for us as I mainly use this to forward emails from outsiders. A poor man’s group inbox if you will :laughing:

I’m just glad that the mystery is now solved and I can move on with my life :rofl: Thanks @nat! :blush: And thanks @JammyDodger for being very patient with me :bowing_man:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.