Using Discourse with SparkPost

email

#1

I can’t get my Discourse installation to work with SparkPost. Let’s say my domain is example.com. I have it registered and verified as a sending domain with SparkPost. The relevant part of my app.yml looks like this:
DISCOURSE_HOSTNAME: 'www.example.com' DISCOURSE_SMTP_ADDRESS: smtp.sparkpostmail.com DISCOURSE_SMTP_PORT: 587 DISCOURSE_SMTP_USER_NAME: SMTP_Injection DISCOURSE_SMTP_PASSWORD: (api key)

Yet when I try to complete my Discourse setup by creating an admin account, I do not receive the confirmation email. What’s going on here? I have read the email support thread.

Thanks!


Email not working with SparkPost
(Rich Leland) #2

Hi @tdsteve - I came across this on the Twitterverse today and whipped up this article for configuring Discourse to use SparkPost - Using SparkPost with Discourse - SparkPost.

Feel free to reach out to us on Twitter (@SparkPostDev) or via our Slack community if you run into any more issues!


(Anton) #3

I can confirm that the guide by the link above works well.
P.S. After the setup is done, a good idea would be to send a test email to mail-tester.com.


(Ernests) #4

If you are running your Discourse on Google Cloud Platform, you have to set your port to 2525 and not to 587.

Google Cloud Platform doesn’t allow outbound connection to ports 25, 465 and 587.

This applies to any email provider.

Learned this hard way while setting up Ghost blog and going mad for couple of days :slight_smile: