Vanilla Importer (vanilla.rb) - Error while importing users


(Hari) #1

Hello,

I am trying to migrate from vanilla into discourse. I am trying the import steps outlined here.

The import job errors out always while importing users (see screenshot attached). When I rerun the script the error repeats for a different user leading me to believe that the issue is not specific to a specific user record but instead a problem with the the db schema or a timeout of some sort (as evidenced by the line in the error dump - “Javascript was terminated either by timeout or explicitly”)

I tried combing thru vanilla.rb to check for timeout values that I can maybe increase but I couldn’t find any such references. Thoughts?


(Hari) #2

Bump. Anyone having a similar issue? I couldn’t find any topics within the meta that addressed a similar issue.


(Régis Hanol) #3

Does that user have a bio by any chances?


(Hari) #4

I dont believe they do. But what I have noticed is that, every time the import job runs, it fails on a different user but with the same error, which leads me to believe that the issue might not be with a specific user but with the timeout not being high enough (my export file from vanilla is pretty huge ~1.2GB).


(Régis Hanol) #5

What are the other errors?


(Hari) #6

Seems to be the same as the previous one.

" ‘eval_unsafe’: Javascript was terminated (either by timeout or explicity)"


(Hari) #7

bump, anyone have a similar issue?


(Régis Hanol) #8

According to the stack trace it’s timing out when “cooking” the bio of that user. Are you sure that your users don’t have any bio?


(Melroy Neil Dsouza) #9

I am experiencing the same issue. No none of my users have bio’s.


(Melroy Neil Dsouza) #10

Looks like a memory issue, i restarted the docker and it worked


(Hari) #11

Same here, issue went away after rebooting the machine and restarting docker. Have a couple of REDIS issues now (seems unrelated) but this timeout was solved by “turnin’ it off and on again” :slight_smile: