Warning: "breadcrumbs issue" and "schema deprecated"

I just a warning from Google’s “Search Console”:

Breadcrumbs issues detected on domain name
data-vocabulary.org schema deprecated

As I say, a warning. Might indicate something worth updating though.

Warnings are suggestions for improvement. Some warnings can enhance your appearance on Search; some might become errors in the future. The following warnings were found on your site:

17 Likes

Got same notification just now

5 Likes

Got it 40 minutes ago and cannot be validated

image

1 Like

I got the same notification.

data-vocabulary.org schema deprecated

1 Like

Hi… Received it also, just now.

1 Like

Hello,

Same here.

1 Like

Got this email today from Google Search:

Search Console has identified that your site is affected by 1 Breadcrumbs issues:

Top Warnings

Warnings are suggestions for improvement. Some warnings can affect your appearance on Search; some might be reclassified as errors in the future. The following warnings were found on your site:

data-vocabulary.org schema deprecated

We recommend that you fix these issues when possible to enable the best experience and coverage in Google Search.

3 Likes

And we just fixed it! See FIX: use schema.org's BreadcrumList · discourse/discourse@96b64df · GitHub. It’ll be in the beta release happening shortly, or if you track tests-passed, upgrade anytime.

29 Likes

Brilliant! This is why I love Discourse as a project. 10/10!

16 Likes

@jomaxro I have updated to beta10 and started a re-validation on the Google Search Console, but the validations are failing. Is beta10 not the release you meant?

1 Like

The commit (GitHub) was in beta10, this should be resolved. I wonder if a rebake is needed @zogstrip? If not, did we miss a spot?

1 Like

Actually, @BryanV can you give an example of a URL Google says failed? I just looked at our search console, checked a few that “failed”, and can’t find data-vocabulary.org where Google says it found it. I see schema.org as expected.

1 Like

@jomaxro I restarted the validation and it seems the old results went away. I’ll respond with what happens on this new validation either way. What’s weird is that the initial validation started off as “is looking good” (google’s verbiage) with several pages being reported fixed, but then a day later it said it had failed after all and listed some pages as failures.

2 Likes

In my report, the # of warnings is still increasing, despite having deployed the update as soon as it was released :thinking:

1 Like

Same question I asked Bryan, can you share a URL or two that Google is saying has the issue?

Sure thing, here are the first three:

https://blenderartists.org/t/render-result-hidden-while-rendering-next-frame/1195990
https://blenderartists.org/t/normal-scale-i-think/506001
https://blenderartists.org/t/locking-an-axis-via-the-ik-solver-in-blender-2-8/1198417
2 Likes

Checked all 3, seeing schema.org not data-vocabulary. I’m starting to think Google’s report is just behind…

Here’s one of your links as viewed by Googlebot. Notice schema.org in the developer tools. I’m guessing if you look at your search console you’ll see the same <div>, but with the deprecated data-vocabulary. Will just need to give Google some time to re-crawl everything and catch up.

9 Likes

In fact google is behind. It isn’t the first time I got trolled by incorrect data provided by google webmaster. The safe zone with google webmaster is to wait for at least 72 hours before taking any action.

6 Likes

@Arta_S I can believe there is a lag, but it must be much more than 72 hours. A week later my third validation attempt failed, and the number of warnings only keeps increasing daily.

Here’s a couple of failed links reporting crawled yesterday:

running bokeh + datashader "dashboard" app on standalone server - Community Support - Bokeh Discourse

ImportError: cannot import name 'return_future' - Community Support - Bokeh Discourse

Just in case there is some confusion on my end about versions, we are on 2.4.0.beta10 (8a89b7e108)

2 Likes

And both are showing schema.org when I check them. At this point, I think we need to treat the warning as what it is, a warning. Give Google whatever time it takes to figure out that we’ve fixed it. Nothing we can do about it at this point.

2 Likes