"Watched words" review queue seems broken

We use the “watched words” feature to enforce a forum rule that requires that crucial public information (like domain names) not be redacted when asking for help. I was pleased to see that they could be configured to go into a review queue.

My expectation was that I would be able to see the post, message the author to explain the rules, and then review the post again if necessary after they revise it, like existing review queues for flagged posts.

Unfortunately, the post is hidden from view completely, and there’s no way to message the author:

I can only Approve or Reject the post, or delete the user, but I don’t want to do any of those!

I can edit the post, and that is the only way to see the actual content, but the edit box is extremely small and can’t be resized:

Plus, I don’t know what the original (un-redacted) words should be. Only the author knows their domain name.

So, this feature is kind of useless for us. I think this must be a bug, surely the post should be visible? How am I supposed to approve or reject it if I can’t see it?

And where’s the option to message the author to discuss the post? Other review queues (flagged posts) have this capability.

How are your watched words configured?

Admin → Customize → Watched Words → Require approval

Sure but what’s the word or phrase triggering the approval? How do you have requires approval configured?

Looking at the approval queue on one of my test sites the post content is visible.

Which version is your site running?

In this case, the word was REDACTED.

I’m not sure what you mean by this. There’s no configuration for “Requires approval” other than setting words.


( c81d4597a7 )

Thanks for the help.

Creating a ‘requires approval’ term of ‘REDACTED’ and posting using a test account gives me this in the review queue:

Have you looked at the page source to see if the term is visible there? Is it possible that this term is used in more than one watched word category?

1 Like

The post content is not in the page source:


The word is not used in any other watched word category.

I’ve also tried to replicate this, but the post contents show in the review queue:

The only thing I notice different in my screenshot and yours is that you seem to have a delete user option, whereas I don’t. I’m thinking this might mean you have another approval setting on top, but I’m not 100% sure. I’m going to try a few things out. Edit: Though looking at @Stephen’s screenshot again, the delete user is in that one too so I think that’s a red herring.

Do you have any plugins or theme components that would be interfering in some way?

Interestingly, when I tried it with a big post, the edit textbox resized itself to accommodate, so hopefully that’s a consequence of the same conflict, and if we solve one we solve both. :slight_smile:

Plugins I have are:

  • discourse_solved
  • docker_manager
  • retort
  • styleguide (disabled)

The only theme customizations I have are a thing called “Custom Header Links”.

Otherwise it’s vanilla Discourse.

In addition to the post content (and the small textbox), what about the ability to message users?

Thanks for your continued help.

Replying to the approval topic in the same way as a ‘something else’ flag isn’t possible as it would post it to the public topic, but you should be able to click on their avatar and pull up their usercard to start a new message from there. :+1:

Gotcha, thanks.

So, now what? The post content still doesn’t appear in the page at all.

The first step would be for me to try and replicate the issue on my test site, and then that would give me a better idea of where we need to look.

So far my step-by-step looks like this:

  • Set REDACTED as Requires Approval under Watched Words
  • Create new test_user
  • Use new test user to post “This is a REDACTED message”
  • Post gets sent to the Review Queue
  • As admin, check the Review Queue
  • Post content is displayed as intended

(Aside: Yesterday I ran the test with an existing test user, which may explain why there was no ‘delete user’ button)

So, as yet, I can’t replicate. Looking at the version number you linked above it looks like you could try updating to Latest from the /admin/upgrade page and seeing if that resolves your issue?

The other general advice is normally to check your site in safe mode to see if any plugins or theme components are interfering, as well as looking in the browser console for any errors when you perform an action (also logged in /logs/).

Are there any more details you can provide that could help me narrow down how to replicate this on my test site?

1 Like

Thanks; I’ll try safe mode when I get a chance.

FWIW, I switched the words from Approval queue to Flagged queue and then the post content appears.

Will keep investigating.