Web.archive audio playlists now have display error

On earlier versions of Discourse, archive.org playlists used to display like this

now however, pasting in that same link results in this, where you can only play the first file through a generic audio player.

Not certain if this is a bug or just an unfortunate result of a larger change to how audio files are displayed, so I’ve just put it under the “ux” category to be safe.

Also, the previous version where they displayed correctly was 2.4.0.beta8 (was on a hosted solution)

1 Like

This may be due to the new onebox allowed iframe domains setting.

1 Like

I tried editing this, but it simply said that "You specified the invalid choice archive.org" (also tried it with http:// and https:// beforehand), so I left it at the default *.

I’m really stumped as to what could be making it display like this. It’s like it’s something that searches pages for playable files, then it sticks them into the display that it thinks would fit best, but it’s obviously not a perfectly one-size-fits-all situation, as it fails to take playlists into account.

Have tried taking away the default “*” and leaving it blank. Same result, sadly.

I think this arises because archive.org always starts you off with the first song of the playlist highlighted.