What happened to the invite links?

admin

regular

Private topic only reachable by people in the granted group during invite.

yes, but only in the same category.

I’m going to try other categories and different forums…

Pretty sure this might be something with private topic, don’t waste more time until I investigate this. Thanks.

1 Like

If that can help you, the recent change on “subcategory can’t be less restrictive than category” hit my forum at some point. Let me check whether it’s the case here…

No, it’s clean. The category has G1/See, G2/CRS, while the subcat has G2/CRS.

FWIW, the bug remains present on v2.3.0.beta4 +12.

Yes I had a busy week on other subjects, will update when fixed, hopefully next week.

2 Likes

It’s getting late here, I will try it again tomorrow, but I think this should fix it:

7 Likes

Good call @joffreyjaffeux. I’m sorry my intervention caused you to overwork, but you indeed fixed it.

1 Like

No worries, it was all my mistake :man_shrugging:

Thanks for the report and waiting for the fix.

1 Like

Now, since we’re talking UX, when I tested the fix, I first clicked the “copy link” button, and expected to be able to cancel that action and come back to the previous screen and click “send invite”. I don’t think it’s important once you know it, but sometimes you may change your mind and then you have to redo it all again.

Anyway thanks! Have a nice day.

I didn’t change this behaviour and I think it’s a tradeoff, you either:

  • optimise for simplicity and speed of the most common use case
  • you make the UI a little bit more complex/slow and make more use cases feel right

In this case I think it’s fine as it is.

4 Likes

@joffreyjaffeux I just realized that I can no longer invite a user (by email or internally) to a topic on mobile since clicking “share” brings up the Android OS “share popup”

1 Like

I believe that was already discussed at some length? I recall it being discussed in the past.

Even when you click the post date?

There’s some discussion on it but it’s unclear as to what the final state was - I inferred we wouldn’t want leave a feature like that as “desktop only”.

I can get the link just fine, or even “Copy to Clipboard” from the share dialog, but I can’t get to the “invite user” modal.

1 Like

Yes in this case it might not show, I can probably do something about it.

3 Likes

FWIW, I often want to invite clients to a discussion that they should see and miss being able I do that in Mobile. Just tune I tried on desktop is /I was unable to find the invite link.

1 Like

Is that an android-only limitation? On iOS once I dismiss the share sheet I see the normal Discourse share/invite dialog.

2 Likes

On Android dismissing the OS dialog does not make the Discourse share modal appear.

2 Likes

I too have noticed this. Looks like we are on Discourse 2.3.0.beta5

iOS :

  1. Press share, iOS share window appears
  2. Select anywhere outside of the share window.
  3. Discourse share appears
  4. Select “Send an invite”
  5. Enter the user name to invite the user.

On iOS the share/invite function is not intuitive at all since the update.

Android:

  1. Under Topic Controls, select Share
  2. Android share window appears, no way to invite users to the thread.
1 Like

That should improve it:

7 Likes