When you add an additional nesting level, all categories, including child categories, are displayed on the categories page

I have added another level of category nesting. But when adding subcategories to a child category, all these categories are displayed on the main page. I plan to create about 100 categories that should be displayed on the main page. There are 30-50 subcategories in each subcategory. Now all categories are displayed on one page. I didn’t find any settings for hiding the categories of the 2nd level of nesting on the main page.

You need to add the “show only child categories” setting so that the entire category tree is not displayed on the main page.
Otherwise, the categories of the second and third degree of nesting will always be displayed on the main page. And if there are thousands of them?

2 Likes

It’s generally considered a bad idea to have more than a couple hundred categories. Maybe have a look at It’s Time We Talked About Tags. The sub sub category feature is largely unsupported last I knew, but perhaps there’s a way to hide them as you wish.

1 Like

Tags are not as structured as the category hierarchy. The subcategory function has been supported for a long time, it should be enabled separately. But the entire category tree is visible. For example, everything works correctly for nodebb. The page displays child subcategories, but does not display categories of a deeper level of nesting.

2 Likes