White blank page on mobile app

Our Discourse forum now works on desktop but connecting via the Discourse app shows a blank white page? On the browser on iOS it also shows a blank page. Even “request the desktop site” shows the blank page? I am hosting the forum on an OVH VPS with DNS records on Cloudflare.

1 Like

Ok, I turned off force https and now it works :grin:


You should not need to do that, non https installs of discourse make no sense


Then how do I fix the blank page on mobile devices? It basically never shows any login page.

Is your site hosted on https? Have you disabled cloud flare acceleration stuff?

What’s cloudflare acceleration stuff?

Is the cloudflare cloud icon orange on your dns page on cloudflare ?

Yes it was. When I disable the acceleration stuff and turn on force https it is again no longer accessible from mobile? I just see a white page which is not very helpful in finding out what is actually going wrong.

Does your site work with https://yoursite

Yes, but only on desktop. On mobile (iOS) in the browser (whether the app of in the browser via mobile of desktop site) I also only see a blank page.

What is terminating SSL, our official let’s encrypt template or some proxy you are running?

I have no idea … I tried the install/setup let’s encrypt but had to start again without it because it does not seem to work with Cloudflare: Setting up HTTPS support with Let's Encrypt

So, is Discourse with https not possible then when using Cloudflare? Surely I am not the only one using Cloudflare, right?

Can you see any errors in the browser console? You might have a mixed content error or a CSP error in there.


If you turn off the Orange cloud you can enable Let’s Encrypt.

If you search here you’ll find many,many people having trouble with CloudFlare. The simplest solution is to turn off the Orange cloud. That will almost certainly solve your problem If you want the orange cloud, then you’ll need to do some searching and some tweaking. Last I looked there wasn’t a decent howto for how to do that.


Thanks! I will check this topic later, for the time being I have turned off the force https thingy

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.