Why installation is not working?

Hello, I thought this installation would be very easy to do but is giving me a really hard day.

I have a domain in GoDaddy. Let’s say is this: www.example.com which is holding a WordPress page.
I’ve called to GoDaddy in order to create a subdomain (forum.example.com) where I wanted to install a Discourse forum.
They told me that I had to create inside my domain>DNS a new A record with the following fields:
Host: forum, Pointing to: My droplet ip (got it after installing Discourse through one-click apps), TTL: 1 hour.

After that, I connected to ssh console and run the setup.
I’ve filled all the fields with my information.
Now when I open the page it says my welcome page, and I put the admin email and says that a mail has been sent and that mail never arrives.

I repeated the installation 5 times with using different ports: 80, 3535, 25, 465, 2525 and anyone is working.

If I open Thunderbird or Outlook, and I put this same information using 465 port, the mail is working. I tried sending mail to my personal mail and worked, and from my personal to this email and I see the emails but not from the installation.

Additional question: If I’m using a GoDaddy subdomain which doesn’t have any nameserver configuration, I’m using the default GoDaddy nameserver. Is that okay?

PS: Why Digital Ocean is selling one-click 5 minutes installation when it’s a false information?

Any ideas?
Thanks.

After checking the log I see this message: Job exception: end of file reached

My goddady email using 465 port.

Any ideas?
Thanks.

You would need to ask them. And I’m pretty sure that whoever wrote that installer is neither expert in Discourse nor is actively maintaining that installer.

The recommended way to install is discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub.

Your problem is likely with whatever your mail server is. You can see discourse/INSTALL-email.md at master · discourse/discourse · GitHub

Rather than re-installing, you can

cd /var/discourse
./discourse-setup

Then, at least, you’ll be doing what is recommended here. (At least mostly; last I looked, it looked like it was a fairly standard install except for their custom script).

3 Likes