Why is my dev server not showing me uploaded images in Topics?


#1

I’ve just made up 2 dev servers in the cloud in 24 hours (don’t worry, wasn’t focusing the whole time :wink: )

I decided to see if a bigger server would improve performance with a dev install, so the current one is a 4 core, 4GB VPS, running 18.04.

Each one of them has had the same issue, so it must be by design (or bug).

Instead of showing me an uploaded image, it is showing the word ‘image’.

The image shows in the preview pane when editing, but not when you view the topic.

Is there some setting that is ‘streamlining’ images because this is a dev server?

Is it due to the fact I’m accessing by IP, not Domain?

Any way to get the server to ‘serve’ images normally - I’m trying to test!

(full disclosure, there is a single plugin installed - Topic List Previews, but this shouldn’t impact/alter the actual view of a post?)

Oh & PPS, there are no errors in the browser console nor in /logs


(Régis Hanol) #2

What are you calling a “dev server”? How did you set it up?


#3

Using:

On a cloud server.


(Régis Hanol) #4

Did you start sidekiq?


#5

Let me check and revert!!!


#6

Yes, but looks like the ‘ProcessPost’ job is failing de to a refused connection … um … this might explain things!

Jobs::ProcessPost {"post_id"=>11, "bypass_bump"=>false, "cooking_options"=>nil, "current_site_id"=>"default"} Jobs::HandledExceptionWrapper: Wrapped Errno::ECONNREFUSED: Failed to open TCP connection to localhost:443 (Connection refused - connect(2) for "localhost" port 443)


#7

Guys, having a dig around, but does anyone know how to run ProcessPost on dev successfully with the otherwise vanilla dev setup (albeit on a cloud server)?

I’ve browsed through a lot of code and configs but can’t see what is forcing ProcessPost to attempt to connect over port 443 …

Had another look at it:

Working link at Preview:

Failed link once submitted:

I guess ‘localhost’ domain is causing the issue?

Any way to avoid the URL having localhost added?


(Jay Pfaffman) #8

There is a dev site setting with a name something like “force hostname”.


#9

So used to the Docker config, which file is that in.

Scrub that got it: site_settings.yml!


#10

@pfaffman that worked a treat! I needed IP and port in that setting’s default!

Thanks a lot, that was really bugging me!!


Topic List Previews