Windows Server 2019 / Hyper-V

Hi there,

I just installed Hyper-v With ubuntu 18.04 and installed Discourse on it. ( )

The Ubuntu server has a static ip given by my router + port forward port 443 from there and pointed my domain to is.The instillation worked if i try to call the command “./launcher start app” it says that discourse is running correctly. But i cannot access it on my domain. It does say under ports : should this be my internal ip of the machine?

if so how to fix it?

Thanks in advance.

It needs a domain name, not an ip. It also needs to be publicly accessible for let’s encrypt to work, and requires extra steps to disable let’s encrypt.


it has a domain name :

You need to make sure that incoming traffic to ports 80 and 443 gets to the server.

Did you run discourse-setup? It tests to see that incoming traffic can get to the server (but can’t work if you have a reverse proxy)

1 Like

Yes i ran

and it did connect fine that’s why i am wondering why it does not work now

Perhaps your server machine uses a different dns than your client. Getting that stuff working between all the layers of your router, the server os, the visualized vm and so on is tricky. It’s not likely that you’ll get that level of troubleshooting here.

That’s why it’s easier to spend $5 or $10 /month to digital ocean.

1 Like