Wordpress Comments Not Showing


I have an issue with comments from Discourse not showing in Wordpress. I’m using Docker containers for Wordpress and Discourse, both sites are newly created.


  • Wordpress 4.9.6
  • Discourse v2.1.0.beta2 +74
  • WP-Discourse 1.6.5


  1. “Join the discussion at” is shown in the post
  2. “Use Discourse Comments” is ON
  3. “Link to Comments Without Displaying Them” is OFF and cannot be enabled (reverts to OFF after clicking Save Options)
  4. “Load Comments With Ajax” does not change behaviour when ON or OFF
  5. “Load Comment CSS” does not change behaviour when ON or OFF
  6. No other plugins are active
  7. Webhook sync has not been configured
  8. SSO does not change behaviour when ON or OFF
  9. Posts in WP do create topics in Discourse
  10. Switching to different default themes does not help

Thank you for any help offered!

Can you check the settings on the WP Discourse Commenting tab? Settings that could prevent comments being pulled across are ‘Min Number of Replies’, ‘Min Score of Posts’, ‘Min Trust Level’, and ‘Only Import Moderator-liked.’ If these settings aren’t preventing comments from being pulled, can you share a link to your WordPress site so that I can take a look?

It can’t be enabled if ‘Use Discourse Comments’ is enabled. You should see a notice about that at the top of the page after you try to save the options.

Thank you for the quick response, it’s late here and I will have to configure either a cloud provider or my home router to give you access, when it’s available over the public internet I’ll follow up with the details.

1 Like

I did check the commenting tab settings, here they are:

  • Min Number of Replies: 0
  • Min Score of Posts: 0
  • Min Trust Level: 0
  • Only Import Moderator-Liked: OFF

I discovered ngrok today and had it setup to enable your review of my WordPress site. Just before I came back to you, the wp-discourse.1.6.6.zip update showed in WP, so I updated.

After the update, comments are showing in posts. I have no further queries, thanks for your time!