Your Docker installation is not working correctly?

docker

#1

Hi, i trying to follow discourse/INSTALL.md at master · discourse/discourse · GitHub

Debian Wheezy
Docker version 1.5

> ./launcher bootstrap app
> time="2015-03-12T17:45:08+01:00" level="fatal" msg="Error response from daemon: Cannot start container f667a79b0a5fd56be273b0619ea67a6ae0ca7458b334d310ab05ac7d0a673f5f: fork/exec /var/lib/docker/init/dockerinit-1.5.0: invalid argument"
> Your Docker installation is not working correctly

> See: https://meta.discourse.org/t/docker-error-on-bootstrap/13657/18?u=sam

Please i need help ^^.


(Régis Hanol) #2

Debian is too much conservative about the package they use which apparently breaks Docker :frowning:


#3

Thanks for your answer.

I can’t not change the system OS i have already many application install on my server and it will be huge work to reinstall all.

Do someone know a workaround to install docker on debian?


(Jens Maier) #4

No, there is no easy workaround, short of installing a backported kernel with aufs support. If that’s not an option and you’re really stuck with Debian wheezy, you might as well attempt an unsupported docker-less installation.