Your site isn't ready to show ads error

I use Communiteq (formerly DiscourseHosting) and their Adsense plugin — I do not know whether this factoid matters but I share it regardless.

Anyhoo, I have added my necessary publisher ID and slot unit ID’s and such in plugin settings, and also added my site and subdomain on Adsense under their Sites settings. However, I have received this error, see attached:

Did I need to add my site to Adsense? If so, do I need to copy and paste their snippet anywhere? Please help clarify this. Thank you.


To add it to the head section, you can create a theme component. Note that the plugin is already going to load the adsbygoogle.js library for you, so once your site is verified by AdSense, you should remove this theme component!

Go to Admin > Customize > Themes > Components and click “Install”. Give it a name like “verify AdSense”.

Then click “Edit CSS/HTML”. In the Common > </head> section, paste the code that AdSense wants to see.

Click Save at the bottom.

Then go to your default theme and add the component.

Now AdSense should be able to find what it wants to see (within 48 hours according to their docs).

Once it shows your site as ready, remove the theme component and fill the plugin’s settings with your publisher ID, ad unit IDs, etc.


Thank you for your clear explanation.

I did this as you said. One concern: I have not placed it anywhere in my top-level domain — only in my subdomain. I had added that subdomain to Sites settings prior to this. It will still scan and accept that, right?

1 Like

I don’t know what AdSense’s rules are about that.

1 Like

Thank you again for your help.

To summarize, I inserted that theme component, and Google came back saying “Ready” and units finally appeared and it seems functional. Then, I have deleted that theme component leaving only my plugin settings in place.

However, Google did say it experienced an error crawling /new/ even though ads appear there…

Do I need to do any further configuration?

1 Like

The “/new” route is only valid when logged in, so I guess you’re supposed to follow these instructions:

Not sure that will actually help since the crawler user won’t see the same topic list as the current user. I wouldn’t worry about that particular page.