Backtick issue due to font

Changing the default font to NotoSans creates a strange bug where backticks are not rendered properly in any text box (See video below for reference):

  1. Only a single backtick is displayed irrespective of how many are typed in
  2. The backticks themselves are indented and overlap the rest of the text

Bug gets resolved when not using NotoSans, which is a shame as it is a beautiful font :frowning:

2 Likes

Unfortunately this is a known problem with the font!

We should probably remove it from our site settings, we already have Open Sans, which is very similar and doesn’t have the backtick issue.

6 Likes

Thanks @awesomerobot. It says the issue was fixed in newer versions - would it be possible to update the font instead of removing it?

4 Likes

So happy to see this topic, this big has driven me bonkers for ages.

Time for me to nix Noto.

So does Doscourse distribute Noto as opposed to using the web font?

2 Likes

We redistribute the fonts in our discourse fonts gem. My take from reading the giant topic on GitHub is that there is a build with this fixed. Not sure we need to nuke Noto, just update the font but deferring to @awesomerobot on this.

6 Likes

Yeah we can just update it, that seems fine!

4 Likes

I’ve updated the font in our gem, so this should be updated soon!

4 Likes