Basic digital ocean install fails on port 443 not accessible

hey I’m trying out the basic Discourse/DigitalOcean guide: discourse/INSTALL-cloud.md at main · discourse/discourse · GitHub

I spent a few (10+) hours bugging around with ports until I got it running. Then understanding mail systems, SMTP, DNS, SSH and too many other things. I got it working eventually but…

Then I (stupidly) decided I wanted to start again from scratch from a new droplet now that I understood it all. (Yay me) And stupidly I deleted the droplet. Now I’ve tried to remake it and I keep getting this error.

Here’s my problem. Starting from a new digitalocean droplet (prior to the mailservers). Either:

(a) following the guide, discourse/INSTALL-cloud.md at main · discourse/discourse · GitHub

sudo -s
git clone https://github.com/discourse/discourse_docker.git /var/discourse
cd /var/discourse
./discourse-setup

or
(b) in the DigitalOcean image marketplace for new droplets and selecting the Discourse image. Then SSH to the droplet, it starts to run the auto setup

Imediately after entering my subdomain to this prompt Hostname for your Discourse? [discourse.example.com]:
Comes up with:

WARNING: Port 443 of computer does not appear to be accessible using hostname:  forum.example.com
WARNING: Connection to http://forum.example.com (port 80) also fails.

I haven’t done anything to my droplet, it’s the original setup. I think the basic setup isn’t working right. Maybe something changed on the digital ocean end since the guide was written?

I see other posts about cloudflare but I don’t have any cloudflare services as far as I know.

I see posts about using ufw to open ports. My first droplet I did this, and eventually got it to work after opening every port I could find a suggestion to open (22, 80, 8080, 8000, 2222, 443, and more) but in any case I think the guide needs to be updated to reflect the need to open ports. And possibly (previous droplet) also needing something like apache2 to listen to the port? Although I’ve been burning my eyeballs across so many errors that I can’t find the old solution.

I am wondering if you understand which ports need to be open and which do not, and can fix both my problem and suggest a correction to the basic guide?

Thank you!

I got (the marketplace droplet image) to run the setup with ufw and opening several ports, some of which I assume are duplicates…

This guide helped:

I think I did:

sudo ufw default deny incoming
sudo ufw default allow outgoing
sudo ufw allow 22
sudo ufw allow 2222
sudo ufw enable
sudo ufw allow http
sudo ufw allow 80
sudo ufw allow https
sudo ufw allow 443

When I run ufw status
I get:

Status: active

To                         Action      From
--                         ------      ----
22/tcp                     ALLOW       Anywhere
80/tcp                     ALLOW       Anywhere
443/tcp                    ALLOW       Anywhere
5000/tcp                   ALLOW       Anywhere
50010                      ALLOW       Anywhere
2222                       ALLOW       Anywhere
80                         ALLOW       Anywhere
443                        ALLOW       Anywhere
22/tcp (v6)                ALLOW       Anywhere (v6)
80/tcp (v6)                ALLOW       Anywhere (v6)
443/tcp (v6)               ALLOW       Anywhere (v6)
5000/tcp (v6)              ALLOW       Anywhere (v6)
50010 (v6)                 ALLOW       Anywhere (v6)
2222 (v6)                  ALLOW       Anywhere (v6)
80 (v6)                    ALLOW       Anywhere (v6)
443 (v6)                   ALLOW       Anywhere (v6)

Will you please send the error message.

It’s likely that you have not created a dns a record pointing to the new droplet.

WARNING: Port 443 of computer does not appear to be accessible using hostname:  forum.example.com
WARNING: Connection to http://forum.example.com (port 80) also fails.

@OverseersMight1 This was the error message above, the setup did not continue from there.

@pfaffman I had a DNS record, it’s possible (relevant for other people) that the TTL was set too high so the changes did not take effect. I set it to the minimum (600) and I suspect that may have helped.

The guide says, " * Your DNS controls should be accessible from the place where you purchased your domain name. Create a DNS A record for the discourse.example.com hostname in your DNS control panel, pointing to the IP address of your cloud instance where you are installing Discourse."

and I did that.

Probably not, or perhaps it’s a propagation issue as you suggest. Without knowing your host name and the ip address of your droplet we can’t check.