Solved icon disappeared

After upgrading to 2.3 beta8, I noticed that the “Solved” glyph is no longer available to select for a topic. I checked the app.yml file and the entries to pull in that plugin are there.
However, if I go to the Settings section of any category, the “Allow topic owner and staff to mark a reply as the solution” is no longer there.

Anyone know what might have happened?

Have you tried safe mode? Do you have any themes that change this glyphs?

I don’t know what safe mode is but no, no themes. We have a very basic installation. We only changed some links at the top

It’s still there as of beta 9. Update to latest, and if it’s still missing give us a list of all of the plugins in your app.yml.

You can access safe mode using yourdiscourseurl/safe-mode and while it disables most stuff it isn’t perfect. I would recommend creating a new theme and previewing using that, with zero customisations and theme extensions applied.

1 Like

We only have the docker_manager (which I assume was always there) and the discourse-solved plugin
This problem has only been the case since v2.3.0.beta8 +164. It was fine with previous betas. Nothing else has changed. We have not changed any of the templates and other than the initial configuration when we installed Discourse last May (e.g, website URL, mail settings and so forth), we haven’t touched that yml file other than when we added the discourse-solved plugin which was at least 6 months ago.

I know there’s a new beta but I typically wait a few days before installing it.

## Plugins go here
## see for details
    - exec:
        cd: $home/plugins
          - git clone
          - git clone

Test-passed should be the default in your app.yml, is that what you’re using? If so you will only receive notifications of new betas, but upgrading will actually update you to the latest in tests-passed, so there’s no real advantage in holding off.

That is good to know. Thanks - I’ll update now and see what happens.

Really appreciate the feedback and help.

OK - after updating to beta 9, the Solved stuff is working again.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.