Bulk Invite error due to unknown UTF-8 character


(VNV Jeep) #1

We’re a cloud client, and was hoping to go live today. I got my .csv together with about 520 unique email addresses, and uploaded it. It said the upload was successful and that I would be getting notifications about it’s status.

Well. That never happened. Nothing happened. About 20 minutes later, I tried it again. Still, nothing. There is no indication it was doing anything… nothing in the logs… no notifications… no new user. About 1 hour into it, I tried again… this time, it looked like 40 user invites went out. Mind you, this is still the same .csv file.

Where are the other 480? Am I doing something wrong? Should I be getting notifications? Should I be seeing 520 invites sitting in the queue?

I emailed support a couple of times this morning, and have not heard anything back yet. Not sure if it’s because of a Eastcoast/Westcoast thing… but I really need an assist here please. I checked meta, and did not find anything where I could try to assist myself on this. I mean, it’s a 1 column .csv file… nothing even remotely complex. Our members are expecting this to happen today. Please help. :confused:

Thank you!


(VNV Jeep) #2

Due to the time contraint, and not hearing from support on this today, I ended up doing most of them manually… one by one. Every once in a while, I would get fed up and go cross-eyed, and I would try to send the remaining addresses through in .csv format… and at times, a small chunk would make it through, and get stuck again.

Overall, this was a very frustrating process. I thought this would have been the easiest part. :frowning:


(Jeff Atwood) #3

I am not sure, can you send the file to @techapj?


(Arpit Jalan) #4

Apologies for delay in reply @VNVJeep! I just sent you a PM, will follow up in that thread.


(VNV Jeep) #5

I sent the .csv in an email earlier yesterday when I emailed support… you guys should have it. Needless to say, I don’t think I’ll have to do this again in the near future, but something that should definitely be looked at as a possible bug?


(Arpit Jalan) #6

I looked into the CSV file and found out that the bulk invite job was failing because of “invalid byte sequence in UTF-8”.

On line number 48 there was an email like “email@example.com�” – this email was raising the exception in bulk invite job and the process was failing.

This is definitely a bug. I will add the code to handle such cases and notify the error in detail via PM. :pencil:


(Arpit Jalan) #7

(VNV Jeep) #8

Excellent! Thank you very much, Arpit!


(Jeff Atwood) #9