Bulk Invite Process Failed No such file or directory @ rb_sysopen

Hi there,

I’ve been trying to upload an csv file for a bulk invite, but each time I receive this message:

Bulk Invite Process Failed – 'No such file or directory @ rb_sysopen

Can someone please help? I am not familiar with Discourse. This is urgent as I am supposed to be launching the entire site by Friday… but that won’t be possible if I can’t invite our users.

Thank you! :slight_smile:

2 Likes

Hi, @lana. Welcome aboard.

I just tested an invite on one my my systems and it worked fine; I don’t remember seeing any reports with invites in recent memory. Did you do a standard install? Did the file you uploaded have a funny name somehow? Did you upload a plain-text csv file? (None if these seems like especially likely explanations).

There is free help here, but if you end up with more money than time I provide paid support.

6 Likes

Hi there,

Is there anyone here from Discourse that could help? I do not have any errors on my list, and Im using an csv file…

Please help :frowning: @techAPJ

1 Like

Are you on latest Discourse version? Also are you seeing any relevant errors in forum.example.com/logs?

I tested locally and bulk invite process works fine for me, so this seems specific to your setup. Maybe try rebuilding the instance and then try again?

cd /var/discourse/
./launcher rebuild app
3 Likes

How did you install discourse?

Hi @techAPJ

thanks for your response!

I’m not sure how we installed Discourse but rebuilding would mean loosing all my configuration right?
I have someone in our tech team trying to help out. Could it be because of a bad internet connexion for instance?

Not at all. It means running the rebuild command to update your instance to the latest version.

cd /var/discourse
./launcher rebuild app
1 Like

Right. Thanks @zogstrip
I think my tech team has found the issue. But it seems too technical for me to understand. Only thing is, when we finally managed to send invites, only 209 out of 340 were showing as Pending.

So was there something wrong with the CSV? This feature has worked well for years now.

2 Likes

I can confirm that this issue is still there. The thing is, it works eventually.

Sometimes I have to upload the same file over and over again until it gets processed correctly.
It always worked out in the end though.

I’ve been doing it at least 6 times now, still no success. You’re lucky @loginerror !

Keep trying! For better effect, wait a few seconds after each click. It’s probably placebo, but works eventually :smiley:

We recently pushed a proper fix here:

This should be no longer an issue.

4 Likes