Can anyone install discourse for me?


(Christopher Khawand) #1

So… I recently got a VPS (hostinger VPS plan 6), well, a powerful one let’s say, here are its specs:

|CPU Cores|8|
|Total CPU Speed|19.2Ghz|
|Memory|8Gb|
|Disk Space|160Gb|
|Bandwidth|8000Gb|

Alright, so I have no experience in VPSs, tried many tutorials online, that told me I have Apache already installed.
I’m using Ubuntu 16.04, and I could provide with SSH details, if anyone can install it for me :slight_smile:
The discourse would be live here: http://forum.cksoftwares.com


#2

Just MHO, but getting someone to help you with a one off install is all very well, but won’t help you for the long term - you need to support your installation in Production and that requires getting dirty occasionally. Without the experience of setting it up yourself that is going to be tricky.

Then again, perhaps you can hire someone to install and support your instance going forward:

https://meta.discourse.org/c/marketplace

and then there is the fully hosted option …


(Christopher Khawand) #3

Yes, but I tried the Apache tutorial on that forum that didn’t work, consumed lots of my time :confused:


#4

@ckhawand it’s a learning process, and PS these are incredibly marketable skills you will pick up, not least:

  • System admin
  • DNS
  • Email services
  • Linux command line
  • SQL

Use the docker guide - that’s the most straightforward, and you can always post individual issues on here if you can’t find the answer here already…

https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md


(Christopher Khawand) #5

Alright, will do follow what you said :slight_smile:


#6

Don’t give up! :slight_smile: There’s a whole community here to help you that will be even more responsive if you ask about specific issues and roadblocks.

btw, you should definitely make this ‘https’ when you get round to it (which is just a case of a setting in app.yml) - you want your traffic to be encrypted to protect yourself and your users.


(Christopher Khawand) #7

Yes, will totally add https when done.
And, will do ask questions when I get stuck :smile:
Thanks for all the help :blush:


(Christopher Khawand) #8

Alright, 1st question:
Install on CentOS 7 or Ubuntu 16.04? :confused:


#9

Ubuntu 16.04 is the OS most people use, go with that.


(Christopher Khawand) #10

Alright, will do! :slight_smile:


(Christopher Khawand) #11

Okay, that’s the issue I’m talking about :confused:
image


#12

take a look at:


(Christopher Khawand) #13

Will do, thanks :slight_smile:


(Christopher Khawand) #14

Okay, after deleting Apache and NGINX using
sudo apt-get remove apache*
sudo apt-get remove nginx*
Then restarting the server, I have been able to proceed to inputing my forum infos.
However, I’m stuck with the Device "docker0" does not exist. issue
checked some topics here, but none of them worked :confused:


#15

Check if anything else is listening on that port … not sure if random offsite links are allowed by found this guide to do this e.g. with netstat:


(Christopher Khawand) #16

Uh, I’m giving up with discourse, will never succeed to install it :confused:


#17

I think your issue is down to how the vanilla build on your hosting VPS is configured … there is probably a really simple modification to get it working.

What did:

netstat -tulpn | grep :80

return?


(Christopher Khawand) #18

Well, it returned udp6


#19

My healthy site returns this:

root@blah:/var/discourse# netstat -tulpn | grep :80
tcp6 0 0 :::80 :::* LISTEN 320/docker-proxy

So this looks like the crux of your problem


(Christopher Khawand) #20

Yes, anyway, my friend installed his discourse one time on his VPS, I’m reaching him out to see if he can do it for me :slight_smile: