Cannot undelete topic/post actions like pinned and split


(Joshua Rosenfeld) #1

Putting this in feature category as I am not sure it is a bug. Certain “admin” functions in a topic result in a “pseudo-post” of sorts, like pinning a topic, unpinning a topic, and splitting a topic. These system generated posts have the ability to be edited, as well as deleted, but unlike a typical post, there does not appear to be a way to undelete them. Is this intentional?


(Joshua Rosenfeld) #2

Going to bump my own (really old) topic here, as I just ran into this issue on another site I run. On this site we have some TL4 users, which means they can pin topics. One of them pinned a topic globally, which should have been just a normal pin, so they unpinned it and re-pinned it. Afterward, they tried to delete the original “pinned globally” small post, but found that it triggered the “to be deleted in 24 hours” text. There’s no option to flag a small post, so this seems like a bug (will make a separate #ux topic, not quite sure it’s #bug level). In any case, allowing for an undelete/cancel delete would solve this, as I (the admin) could then go and delete it without the delay.


(Jeff Atwood) #3

Hmm I wonder if we should disallow TL4 users from pinning globally, that seems very risky?


(Joshua Rosenfeld) #4

I would be very much against that personally. On the site this report is coming from, TL4 users do pin globally, and have reasons for doing so. This was an innocent mistake that the user realized and was cleaning up. We have a definitely need for users to be able to pin (including globally) but not get access to /admin or /flags.


Edit: disabling TL4 global pinning also will not do anything to solve the original issue, which affects site staff too.