Can't adjust mention settings for automatic "everyone" group


Go to and change the setting as follows:

Expected result:

The group settings are changed so I can message everyone.

Actual result:

See above for “Name has already been taken” error.


Yes, the inputs should be “read only” similar to the “automatic” Badges.

Or maybe you’re looking for the trust_level_0 group ?

No, trust_level_0 is a very small percentage of our user base. As an admin, I want to send a private message to everyone by addressing the message to that group.

Check again. I’m pretty sure every active member is in the trust_level_0 group


Hmm, not sure here, @sam should have a look.


everyone should be hidden from that UI it is a meta group that encompasses all logged out users as well. Clearly that option makes no sense there.

TL0 group covers all users that have accounts on Discourse.


So to answer the request that @codinghorror often refers to MailChimp, if we want to send a message to every user, an admin just creates a PM to the trust_level_0 group?


I mentioned this elsewhere:


Just to “piggy back” on this topic. Today I realized that any new user (even trust level 0) can easily @mention “everyone” group. Which isn’t something too wise to leave enabled.

After going to the admin panel and selecting “Only Moderators and Admins” can message and mention this group, this is the error I keep getting…

Can this be fixed somehow?
P.s. Not super important but it would be great to opt out some users from ever being found on the mention list. One of the most obvious examples would be the “system” user.

Did you by any chance find a fix to this, @downey or @DeanMarkTaylor?

We’ve had two cases now where user level 0 and level 1 bothered the whole community by @mentioning “everyone” group. It surely needs to be hidden from anyone, apart from admins and mods perhaps.

@sam you mentioned “everyone should be hidden from that UI” Any suggestions how? Or is this still an existing bug?

This is not possible on a default Discourse install:

So you must have modified default settings to make that mention possible.

Thanks @codinghorror, I’ll take a look at the settings. I don’t think I changed anything though. Also, I just tried it here on Discourse meta, and I can mention everyone without a problem. (Screenshot below)

It is visible, as you can see in the screenshot the “visible to all users” is checked (@sam do we need this to be visible to all users by default? That seems weird), but typing it won’t do anything. Try it yourself if you don’t believe me.

Regardless we’ll double check this and get back.

Ok, I was able to select it, and on the preview it shows as a legit @mention of “Everyone” group. I won’t dare to hit the post button for obvious reasons.

I’ll just have to try a fresh install with out of the box settings and see if I can still replicate.

Btw my current settings also say “Nobody” can mention it.

Hey @codinghorror and @sam, Just replicated the same problem on a fresh install as well as on Discourse test forum here:

In the end, any brand new (even trust level 0) user can start interrupting and bothering everyone who’s ever (Evn logged out) joined the particular forum.

Fwiw I did not get mentioned on try

Will investigate this Monday


Typing @everyone does not mention @everyone on the site, the bug reported here is that if people want to make it a legit mention target (so it spams 100s or even 100s of thousands of users) then they can not do so.

I can amend the defaults here, but it would be a bit weird to kill the visible @everyone page and keep the @trust_level_0 one around.

1 Like

Where is this “everyone” page?

aha… that page is broken …

I guess tl0 works

Will remove the visible flag from everyone

Why was it ever visible and type-able, this makes absolutely zero sense to me.