Can't bulk upload censored words


I’m a moderator on a Discourse forum, and I’m trying to bulk upload a .txt file of words I would like to be censored. I have one word per line in the file. However, when I got to Admin > Customise > Censor and click Add from file, it blocks the words instead of censoring them.

I tried doing the same thing inside of Require Approval, and the words then got censored instead of being put in the Require Approval list.

Our community is using Discourse 2.9.0 beta 4 (6268fe7495)

The only installed plugins are docker_manager and styleguide.

Please could this get fixed soon? If this is an issue for our forum, how do we fix it?



I know you are a moderator. But this might be it.

I wonder whether asking the admin to go to the site settings and looking up authorized extensions might help resolve this.

I can repro this (as an admin) on 2.9.0.beta4 ( d065ec0f7b )
seems to be limited to the bulk upload (as word by word, it works as intended)


when trying Require Approval, the list also ends up blocked


Thanks @DillonB07 for reporting this issue.

@flink91 worked on a fix and it just got merged :+1:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.