Can't run ./launcher rebuild app - Docker storage driver is unsupported


(Adrian D'atri Guiran) #49

For me this didn’t work, i had to use:

DOCKER_OPTS="--storage-driver=overlay"

You can confirm if it works for you by running:

docker info | grep Storage

(Adi Adi) #50

@sam Hi I am still unable to change device storage. Tried all above mentioned process.
Aws ubuntu 12.04 precise 3.2.* kernel
Can anyone help!!!


(Jeff Atwood) #51

Ubuntu 12.04? Why bother, that’s so old!


(Adi Adi) #52

Current live production server is 12.04 precise 3.2.* kernel…so only


(Jay Pfaffman) #53

End of life for precise is now: Release end of life | Ubuntu

It’s time to upgrade.


(Edgar Martinez) #54

Hi @kraml I created a partition with the indicated format ext4, make a copy of /var/lib/docker named /var/lib/docker_old and leave a copy of /var/lib/docker with all its files, mount my partition With the correct type of FS with the command
Sudo mount /dev/sda1/ /var/lib/docker, as I have RHEL also make the prompts to create the docker.conf inside /etc/systemd/system/docker.service.d/ specifying ExecStart=/usr/bin/dockerd --storage-driver=overlay but I can not get it to start the Docker service since it gives me the following error:

[Cevmf @ server discourse] $ sudo systemctl status docker -l
[Sudo] password for cevmf:
● docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/docker.service.d
           └─docker.conf
   Active: failed (Result: exit-code) since Wed 2017-05-03 14:13:32 EDT; 7 minutes ago
     Docs: https://docs.docker.com
  Process: 8961 ExecStart=/usr/bin/dockerd --storage-driver=overlay (code=exited, status=1 / FAILURE)
 Main PID: 8961 (code=exited, status=1 / FAILURE)
   Memory: 1.5M
   CGroup: /system.slice/docker.service

May 03 14:13:31 server dockerd [8961]: time="2017-05-03T14: 13: 31.970782327-04: 00" level=info msg="libcontainerd: new containerd process, pid: 8964"
May 03 14:13:32 server dockerd [8961]: Error starting daemon: error initializing graphdriver: invalid argument

Any ideas?


(Jay Pfaffman) #55

That’s really more of a Docker/sysadmin question. You might try on a docker forum or stackexchange.


(Matt Palmer) #56

Remove the spaces around the equals. Spaces separate command line arguments, they’re not just for aesthetics.


(Kai Liu) #57

Besides of what Matt mentioned about spaces around “=”, here you also missed a space between the partition and the mount dir. Was it only a typo in your post or you actually ran the command like this?


(Edgar Martinez) #58

Sorry when I copied the text in the page something made those changes, I corrected it, and yes the mount command was written with a space mount /dev/sda1 /var/lib/docker


(Edgar Martinez) #59

Thanks Matt I don´t know why it pasted like that, but I corrected it.


(Edgar Martinez) #60

It finally work and with the Discourse new version so far v1.8.0.beta11 +87 Thanks all for your help @kraml [quote=“kraml, post:47, topic:56927”]
You can:

Stop your forum and docker daemon.
Move/rename the /var/lib/docker folder.
Backup /var/discourse.
Change docker storage driver.
Start up docker daemon. Then you will notice your discourse container is gone. Don’t panic, it’s only the container definition gone, not data.
run launcher bootstrap and you will get a new container created and still pointing to your existing data. Your site will just up running without change.
[/quote]


(Edgar Martinez) #61

Hi @kraml I made it works in my sandbox server, but when i try the same thing in my production server I have the bootstrap error, and I have my docker working in a partition FSType 1 is mounted fine and I did the steps you mencioned

  • Stop the service
  • Mount the var/lib/docker in the partition
  • restart the daemon
  • start the service (all fine)
  • go to /var/discourse
  • launch the bootstrap and have the same error

    Any advice?

(Kai Liu) #62

The log you copied in screenshot don’t help in diagnose the problem, you need to provide the full rebuild log.

It is high probable that one of your plugin caused the rebuild problem, if you are sure you have done the right steps regarding filesystem.


(Edgar Martinez) #63

The final step was rename folder /var/discourse, and make a new install, good luck i have a backup and now my site is up and with all the data.


#65

thanks! I can confirm that this works great on a Linode running Ubuntu 14.04. Note that I was not able to actually stop the app because of the launcher storage driver error message.


(Nukeador) #66

This seems to be the only thing that worked on my Ubuntu 16.04, thanks! :slight_smile:


#67

In a similar situation (Debian 8 Jessie)

“Your Docker installation is not using a supported storage driver”

Docker info
Storage Driver: devicemapper

# cat /etc/debian_version
8.9

# dpkg --get-selections | grep linux-image
linux-image-3.16.0-4-amd64          install
linux-image-amd64                   install

# dpkg -L linux-image-3.16.0-4-amd64 | grep aufs
/lib/modules/3.16.0-4-amd64/kernel/fs/aufs
/lib/modules/3.16.0-4-amd64/kernel/fs/aufs/aufs.ko

Solution was to create new file: /etc/docker/daemon.json

{
  "storage-driver": "aufs"
}
service docker restart

(Cy) #68

This basically saved my life. Worked like a charm in my EC2 Linux instance and relived it.


(Julian) #69

According with:

For Ubuntu 14.04 version, you must install linux-image-extra-* package before install docker.
So if you already installed docker, you should uninstall it first before start to install linux-image-extra-* package.
sudo apt-get purge docker-ce
sudo rm -rf /var/lib/docker
sudo rm /etc/systemd/system/docker.service

Then install linux-image-extra-*

sudo apt-get update

sudo apt-get install \
    linux-image-extra-$(uname -r) \
    linux-image-extra-virtual

and finally reinstall docker from git

wget -qO- https://get.docker.com/ | sh

regards :ok_hand: