Can't select avatar from list after updating to Discourse 2.4.0.beta1

Our Discourse installation uses the list of allowed avatars feature to avoid the chance of users uploading inappropriate avatars. We updated from 2.3.0.beta11 to 2.4.0.beta1 yesterday and now when users try to change their avatar, they don’t see the avatar choices we have defined in the admin settings page; it’s just an empty window:
image

I tried adding a new image to the selection options but that didn’t show up as an option either. I tried disabling and enabling the selectable avatars feature, but it had no effect. I tried rebuilding the docker container a second time to make sure it wasn’t some kind of weird problem with the build but the issue is still occuring.

I’m having the same problem. I think it appeared a couple betas ago. I first noticed it when there were no avatars to choose from (as described in Selectable avatar quirks), but now there are avatars added and I get the same empty “change your profile picture.” I tried safe mode, but there are a bunch of plugins that could be causing a problem.

The solution I’m attempting is to convince the site admin that forcing people to use a set of avatars is a bad idea. :slight_smile:

Thanks for the report, @bmc, this should fix the issue: FIX: use correct name for selectable_avatars_enabled site setting · discourse/discourse@f096c99 · GitHub

11 Likes