Can't ssh to container on fresh install


(Alexander) #1

Just set up Discourse (stable) on Debian 8.1 (2 gigs DO droplet) following this guide discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub

After bootstraping and starting app I can’t ssh into container because of incorrect root password. I also tried fresh install with this settings in app.yml:

  • exec: /usr/sbin/usermod -p “$(mkpasswd -m sha-256 ‘SuperPassword’)” root. Same result.

So what is the correct way to configure ssh access? Thanks.

P.S. Installation was made by root if it does matter.


(Felix Freiberger) #2

Do you actually need to SSH into the container? A simple ./launcher enter app should always work to get a shell inside the container. I’ve never really needed SSH :slight_smile:


(Alexander) #3

Yes, I really need this for remote access.


(Felix Freiberger) #4

You could always SSH into the host, and then enter the container :wink:

But of course, SSH into the container should also be working. Unluckily, I have no idea why it isn’t working for you.


(Sam Saffron) #5

I removed most of the ssh hacks a while ago, they were getting a bit unwieldy, you could still mixin the ssh template and figure out how to wire it all up but it’s tricky


(Alexander) #6

Thanks for info @sam!


(Jeff Atwood) #7